python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / openbox / openbox.mk
blobb5148e00e8213ae996232c2160784ea5514b1784
1 ################################################################################
3 # openbox
5 ################################################################################
7 OPENBOX_VERSION = 3.6.1
8 OPENBOX_SOURCE = openbox-$(OPENBOX_VERSION).tar.xz
9 OPENBOX_SITE = http://openbox.org/dist/openbox
10 OPENBOX_LICENSE = GPLv2+
11 OPENBOX_LICENSE_FILES = COPYING
13 OPENBOX_CONF_OPTS = \
14 --x-includes=$(STAGING_DIR)/usr/include/X11 \
15 --x-libraries=$(STAGING_DIR)/usr/lib
17 OPENBOX_DEPENDENCIES = xlib_libX11 libxml2 libglib2 pango host-pkgconf
19 ifeq ($(BR2_PACKAGE_IMLIB2_X),y)
20 OPENBOX_CONF_OPTS += --enable-imlib2
21 OPENBOX_DEPENDENCIES += imlib2
22 else
23 OPENBOX_CONF_OPTS += --disable-imlib2
24 endif
26 ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
27 OPENBOX_CONF_OPTS += --enable-startup-notification
28 OPENBOX_DEPENDENCIES += startup-notification
29 else
30 OPENBOX_CONF_OPTS += --disable-startup-notification
31 endif
33 ifeq ($(BR2_PACKAGE_XLIB_LIBSM),y)
34 OPENBOX_CONF_OPTS += --enable-session-management
35 OPENBOX_DEPENDENCIES += xlib_libSM
36 else
37 OPENBOX_CONF_OPTS += --disable-session-management
38 endif
40 ifeq ($(BR2_PACKAGE_XLIB_LIBXINERAMA),y)
41 OPENBOX_CONF_OPTS += --enable-xinerama
42 OPENBOX_DEPENDENCIES += xlib_libXinerama
43 else
44 OPENBOX_CONF_OPTS += --disable-xinerama
45 endif
47 ifeq ($(BR2_PACKAGE_XLIB_LIBXRANDR),y)
48 OPENBOX_CONF_OPTS += --enable-xrandr
49 OPENBOX_DEPENDENCIES += xlib_libXrandr
50 else
51 OPENBOX_CONF_OPTS += --disable-xrandr
52 endif
54 ifeq ($(BR2_PACKAGE_XLIB_LIBXCURSOR),y)
55 OPENBOX_DEPENDENCIES += xlib_libXcursor
56 OPENBOX_CONF_OPTS += --enable-xcursor
57 else
58 OPENBOX_CONF_OPTS += --disable-xcursor
59 endif
61 $(eval $(autotools-package))