1 ################################################################################
5 ################################################################################
7 OPENVMTOOLS_VERSION
= 5a9033ddfa95786d867e4d02bbb9a29bac8fb64f
8 OPENVMTOOLS_SITE
= $(call github
,vmware
,open-vm-tools
,$(OPENVMTOOLS_VERSION
))
9 OPENVMTOOLS_SUBDIR
= open-vm-tools
10 OPENVMTOOLS_LICENSE
= LGPLv2.1
11 OPENVMTOOLS_LICENSE_FILES
= $(OPENVMTOOLS_SUBDIR
)/COPYING
13 # Autoreconf needed or config/missing will run configure again at buildtime
14 OPENVMTOOLS_AUTORECONF
= YES
15 OPENVMTOOLS_CONF_OPTS
= --with-dnet \
16 --without-icu
--without-x
--without-gtk2 \
17 --without-gtkmm
--without-kernel-modules \
18 --disable-deploypkg
--without-xerces
19 OPENVMTOOLS_CONF_ENV
+= CUSTOM_DNET_CPPFLAGS
=" "
20 OPENVMTOOLS_DEPENDENCIES
= libglib2 libdnet
22 # When libfuse is available, openvmtools can build vmblock-fuse, so
23 # make sure that libfuse gets built first
24 ifeq ($(BR2_PACKAGE_LIBFUSE
),y
)
25 OPENVMTOOLS_DEPENDENCIES
+= libfuse
28 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
29 OPENVMTOOLS_CONF_OPTS
+= --with-ssl
30 OPENVMTOOLS_DEPENDENCIES
+= openssl
32 OPENVMTOOLS_CONF_OPTS
+= --without-ssl
35 ifeq ($(BR2_PACKAGE_OPENVMTOOLS_PROCPS
),y
)
36 OPENVMTOOLS_CONF_OPTS
+= --with-procps
37 OPENVMTOOLS_DEPENDENCIES
+= procps-ng
39 OPENVMTOOLS_CONF_OPTS
+= --without-procps
42 ifeq ($(BR2_PACKAGE_OPENVMTOOLS_PAM
),y
)
43 OPENVMTOOLS_CONF_OPTS
+= --with-pam
44 OPENVMTOOLS_DEPENDENCIES
+= linux-pam
46 OPENVMTOOLS_CONF_OPTS
+= --without-pam
49 # symlink needed by lib/system/systemLinux.c (or will cry in /var/log/messages)
50 # defined in lib/misc/hostinfoPosix.c
51 # /sbin/shutdown needed for Guest OS restart/shutdown from hypervisor
52 define OPENVMTOOLS_POST_INSTALL_TARGET_THINGIES
53 ln
-fs os-release
$(TARGET_DIR
)/etc
/lfs-release
54 if
[ ! -e
$(TARGET_DIR
)/sbin
/shutdown
]; then \
55 $(INSTALL
) -D
-m
755 package
/openvmtools
/shutdown \
56 $(TARGET_DIR
)/sbin
/shutdown
; \
60 OPENVMTOOLS_POST_INSTALL_TARGET_HOOKS
+= OPENVMTOOLS_POST_INSTALL_TARGET_THINGIES
62 define OPENVMTOOLS_INSTALL_INIT_SYSV
63 $(INSTALL
) -D
-m
755 package
/openvmtools
/S10vmtoolsd \
64 $(TARGET_DIR
)/etc
/init.d
/S10vmtoolsd
67 define OPENVMTOOLS_INSTALL_INIT_SYSTEMD
68 $(INSTALL
) -D
-m
644 package
/openvmtools
/vmtoolsd.service \
69 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/vmtoolsd.service
70 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
71 ln
-fs ..
/..
/..
/..
/usr
/lib
/systemd
/system
/vmtoolsd.service \
72 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/vmtoolsd.service
75 $(eval
$(autotools-package
))