python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / pcre / pcre.mk
blobe302ed7d8d95eb4b346af11aebac7bb04cee5e55
1 ################################################################################
3 # pcre
5 ################################################################################
7 PCRE_VERSION = 8.40
8 PCRE_SITE = https://ftp.pcre.org/pub/pcre
9 PCRE_SOURCE = pcre-$(PCRE_VERSION).tar.bz2
10 PCRE_LICENSE = BSD-3c
11 PCRE_LICENSE_FILES = LICENCE
12 PCRE_INSTALL_STAGING = YES
13 PCRE_CONFIG_SCRIPTS = pcre-config
15 # They're required for host-libglib2
16 HOST_PCRE_CONF_OPTS = --enable-unicode-properties
18 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
19 # pcre will use the host g++ if a cross version isn't available
20 PCRE_CONF_OPTS = --disable-cpp
21 endif
23 PCRE_CONF_OPTS += --enable-pcre8
24 PCRE_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE_16),--enable-pcre16,--disable-pcre16)
25 PCRE_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE_32),--enable-pcre32,--disable-pcre32)
26 PCRE_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE_UTF),--enable-utf,--disable-utf)
27 PCRE_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE_UCP),--enable-unicode-properties,--disable-unicode-properties)
29 $(eval $(autotools-package))
30 $(eval $(host-autotools-package))