python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / procps-ng / procps-ng.mk
blob0f8b20c5608a1641297ef7cd90c5fc4d97b0e5d5
1 ################################################################################
3 # procps-ng
5 ################################################################################
7 PROCPS_NG_VERSION = 3.3.12
8 PROCPS_NG_SOURCE = procps-ng-$(PROCPS_NG_VERSION).tar.xz
9 PROCPS_NG_SITE = http://downloads.sourceforge.net/project/procps-ng/Production
10 PROCPS_NG_LICENSE = GPLv2+, LGPLv2+ (libproc and libps)
11 PROCPS_NG_LICENSE_FILES = COPYING COPYING.LIB
12 PROCPS_NG_INSTALL_STAGING = YES
13 PROCPS_NG_DEPENDENCIES = ncurses host-pkgconf
14 # For 0002-use-pkgconfig-for-ncursesw-cflags.patch
15 PROCPS_NG_AUTORECONF = YES
16 PROCPS_NG_GETTEXTIZE = YES
18 # If both procps-ng and busybox are selected, make certain procps-ng
19 # wins the fight over who gets to have their utils actually installed.
20 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
21 PROCPS_NG_DEPENDENCIES += busybox
22 endif
24 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
25 PROCPS_NG_DEPENDENCIES += gettext
26 PROCPS_NG_CONF_OPTS += LIBS=-lintl
27 endif
29 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
30 PROCPS_NG_DEPENDENCIES += systemd
31 PROCPS_NG_CONF_OPTS += --with-systemd
32 else
33 PROCPS_NG_CONF_OPTS += --without-systemd
34 endif
36 # Make sure binaries get installed in /bin, so that they overwrite
37 # their busybox counterparts.
38 # Make sure libprocps.pc is installed in STAGING_DIR/usr/lib/pkgconfig/
39 # otherwise it's installed in STAGING_DIR/lib/pkgconfig/ breaking
40 # pkg-config --libs libprocps.
41 PROCPS_NG_CONF_OPTS += --exec-prefix=/ \
42 --libdir=/usr/lib
44 # Allows unicode characters to show in 'watch'
45 ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
46 PROCPS_NG_CONF_OPTS += \
47 --enable-watch8bit
48 endif
50 # numa support requires libdl, so explicitly disable it when
51 # BR2_STATIC_LIBS=y
52 ifeq ($(BR2_STATIC_LIBS),y)
53 PROCPS_NG_CONF_OPTS += --disable-numa
54 endif
56 $(eval $(autotools-package))