1 ################################################################################
5 ################################################################################
7 PROFTPD_VERSION
= 1.3.5d
8 PROFTPD_SITE
= ftp
://ftp.proftpd.org
/distrib
/source
9 PROFTPD_LICENSE
= GPLv2
+
10 PROFTPD_LICENSE_FILES
= COPYING
13 ac_cv_func_setpgrp_void
=yes \
14 ac_cv_func_setgrent_void
=yes
17 --localstatedir
=/var
/run \
26 ifeq ($(BR2_PACKAGE_PROFTPD_MOD_REWRITE
),y
)
27 PROFTPD_CONF_OPTS
+= --with-modules
=mod_rewrite
30 # configure script doesn't handle detection of %llu format string
31 # support for printing the file size when cross compiling, breaking
32 # access for large files.
33 # We unfortunately cannot AUTORECONF the package, so instead force it
34 # on if we know we support it
35 define PROFTPD_USE_LLU
36 $(SED
) 's/HAVE_LU/HAVE_LLU/' $(@D
)/configure
38 PROFTPD_PRE_CONFIGURE_HOOKS
+= PROFTPD_USE_LLU
40 define PROFTPD_MAKENAMES
41 $(MAKE1
) CC
="$(HOSTCC)" CFLAGS
="" LDFLAGS
="" -C
$(@D
)/lib
/libcap _makenames
44 PROFTPD_POST_CONFIGURE_HOOKS
= PROFTPD_MAKENAMES
46 PROFTPD_MAKE
= $(MAKE1
)
48 define PROFTPD_INSTALL_TARGET_CMDS
49 $(INSTALL
) -D
-m
0755 $(@D
)/proftpd
$(TARGET_DIR
)/usr
/sbin
/proftpd
50 $(INSTALL
) -m
0644 -D
$(@D
)/sample-configurations
/basic.conf
$(TARGET_DIR
)/etc
/proftpd.conf
54 ftp
-1 ftp
-1 * /home
/ftp
- - Anonymous FTP User
57 define PROFTPD_INSTALL_INIT_SYSV
58 $(INSTALL
) -D
-m
0755 package
/proftpd
/S50proftpd
$(TARGET_DIR
)/etc
/init.d
/S50proftpd
61 define PROFTPD_INSTALL_INIT_SYSTEMD
62 $(INSTALL
) -D
-m
644 package
/proftpd
/proftpd.service \
63 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/proftpd.service
64 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
65 ln
-sf ..
/..
/..
/..
/usr
/lib
/systemd
/system
/proftpd.service \
66 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/proftpd.service
69 $(eval
$(autotools-package
))