python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / pure-ftpd / pure-ftpd.mk
blob95e7065580fba9221c5bac553c1a2f35713833b3
1 ################################################################################
3 # pure-ftpd
5 ################################################################################
7 PURE_FTPD_VERSION = 1.0.42
8 PURE_FTPD_SITE = http://download.pureftpd.org/pub/pure-ftpd/releases
9 PURE_FTPD_SOURCE = pure-ftpd-$(PURE_FTPD_VERSION).tar.bz2
10 PURE_FTPD_LICENSE = ISC
11 PURE_FTPD_LICENSE_FILES = COPYING
12 PURE_FTPD_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
14 PURE_FTPD_CONF_OPTS = \
15 --with-altlog \
16 --with-puredb \
17 --with-rfc2640
19 ifeq ($(BR2_PACKAGE_ELFUTILS),y)
20 PURE_FTPD_DEPENDENCIES += elfutils
21 endif
23 ifeq ($(BR2_PACKAGE_LIBCAP),y)
24 PURE_FTPD_CONF_OPTS += --with-capabilities
25 PURE_FTPD_DEPENDENCIES += libcap
26 else
27 PURE_FTPD_CONF_OPTS += --without-capabilities
28 endif
30 ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
31 PURE_FTPD_DEPENDENCIES += libsodium
32 endif
34 ifeq ($(BR2_PACKAGE_OPENSSL),y)
35 PURE_FTPD_CONF_OPTS += --with-tls
36 PURE_FTPD_DEPENDENCIES += openssl
37 ifeq ($(BR2_STATIC_LIBS),y)
38 PURE_FTPD_CONF_ENV += LIBS='-lssl -lcrypto -lz'
39 endif
40 else
41 PURE_FTPD_CONF_OPTS += --without-tls
42 endif
44 ifeq ($(BR2_TOOLCHAIN_SUPPORTS_PIE),)
45 PURE_FTPD_CONF_ENV += ax_cv_check_cflags___fPIE=no ax_cv_check_ldflags___fPIE=no
46 endif
48 ifeq ($(BR2_PACKAGE_PURE_FTPD_FTPWHO),y)
49 PURE_FTPD_CONF_OPTS += --with-ftpwho
50 endif
52 ifeq ($(BR2_PACKAGE_PURE_FTPD_QUOTAS),y)
53 PURE_FTPD_CONF_OPTS += --with-quotas
54 endif
56 $(eval $(autotools-package))