python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / raptor / raptor.mk
blob26536633074d4b7c28ce759d1422e83aa8f3a5c6
1 ################################################################################
3 # raptor
5 ################################################################################
7 RAPTOR_VERSION = 2.0.15
8 RAPTOR_SOURCE = raptor2-$(RAPTOR_VERSION).tar.gz
9 RAPTOR_SITE = http://download.librdf.org/source
10 RAPTOR_DEPENDENCIES = libxml2 libxslt
11 RAPTOR_LICENSE = GPLv2+ or LGPLv2.1+ or Apache-2.0+
12 RAPTOR_LICENSE_FILES = LICENSE.txt
13 RAPTOR_INSTALL_STAGING = YES
15 # Flag is added to make sure the patch is applied for the configure.ac of raptor.
16 RAPTOR_AUTORECONF = YES
18 RAPTOR_CONF_OPTS =\
19 --with-xml2-config=$(STAGING_DIR)/usr/bin/xml2-config \
20 --with-xslt-config=$(STAGING_DIR)/usr/bin/xslt-config
22 ifeq ($(BR2_PACKAGE_LIBCURL),y)
23 RAPTOR_DEPENDENCIES += libcurl
24 RAPTOR_CONF_OPTS += --with-curl-config=$(STAGING_DIR)/usr/bin/curl-config
25 else
26 RAPTOR_CONF_OPTS += --with-curl-config=no
27 endif
29 ifeq ($(BR2_PACKAGE_YAJL),y)
30 RAPTOR_DEPENDENCIES += yajl
31 RAPTOR_CONF_ENV += LIBS="-lm"
32 RAPTOR_CONF_OPTS += --with-yajl=$(STAGING_DIR)/usr
33 else
34 RAPTOR_CONF_OPTS += --with-yajl=no
35 endif
37 ifeq ($(BR2_PACKAGE_ICU),y)
38 RAPTOR_DEPENDENCIES += icu
39 RAPTOR_CONF_OPTS += --with-icu-config=$(STAGING_DIR)/usr/bin/icu-config
40 else
41 RAPTOR_CONF_OPTS += --with-icu-config=no
42 endif
44 $(eval $(autotools-package))