python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / rpm / rpm.mk
blob1c03f2eaa1a73b6c18371502e1a77bf9adfc7a37
1 ################################################################################
3 # rpm
5 ################################################################################
7 RPM_VERSION_MAJOR = 4.13
8 RPM_VERSION = $(RPM_VERSION_MAJOR).0.1
9 RPM_SOURCE = rpm-$(RPM_VERSION).tar.bz2
10 RPM_SITE = http://ftp.rpm.org/releases/rpm-$(RPM_VERSION_MAJOR).x
11 RPM_DEPENDENCIES = host-pkgconf berkeleydb file popt zlib
12 RPM_LICENSE = GPLv2 or LGPLv2 (library only)
13 RPM_LICENSE_FILES = COPYING
14 RPM_PATCH = \
15 https://github.com/rpm-software-management/rpm/commit/b5f1895aae096836d6e8e155ee289e1b10fcabcb.patch \
16 https://github.com/rpm-software-management/rpm/commit/c810a0aca3f1148d2072d44b91b8cc9caeb4cf19.patch
18 # b5f1895aae096836d6e8e155ee289e1b10fcabcb.patch
19 # c810a0aca3f1148d2072d44b91b8cc9caeb4cf19.patch
20 RPM_AUTORECONF = YES
22 RPM_CONF_OPTS = \
23 --disable-python \
24 --disable-rpath \
25 --with-external-db \
26 --with-gnu-ld \
27 --without-cap \
28 --without-hackingdocs \
29 --without-lua
31 ifeq ($(BR2_PACKAGE_ACL),y)
32 RPM_DEPENDENCIES += acl
33 RPM_CONF_OPTS += --with-acl
34 else
35 RPM_CONF_OPTS += --without-acl
36 endif
38 ifeq ($(BR2_PACKAGE_LIBNSS),y)
39 RPM_DEPENDENCIES += libnss
40 RPM_CONF_OPTS += --without-beecrypt
41 RPM_CFLAGS += -I$(STAGING_DIR)/usr/include/nss -I$(STAGING_DIR)/usr/include/nspr
42 else
43 RPM_DEPENDENCIES += beecrypt
44 RPM_CONF_OPTS += --with-beecrypt
45 RPM_CFLAGS += -I$(STAGING_DIR)/usr/include/beecrypt
46 endif
48 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
49 RPM_DEPENDENCIES += gettext
50 RPM_CONF_OPTS += --with-libintl-prefix=$(STAGING_DIR)/usr
51 else
52 RPM_CONF_OPTS += --without-libintl-prefix
53 endif
55 ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)
56 RPM_DEPENDENCIES += libarchive
57 RPM_CONF_OPTS += --with-archive
58 else
59 RPM_CONF_OPTS += --without-archive
60 endif
62 ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
63 RPM_DEPENDENCIES += libselinux
64 RPM_CONF_OPTS += --with-selinux
65 else
66 RPM_CONF_OPTS += --without-selinux
67 endif
69 # For the elfutils and binutils dependencies, there are no
70 # configuration options to explicitly enable/disable them.
71 ifeq ($(BR2_PACKAGE_ELFUTILS),y)
72 RPM_DEPENDENCIES += elfutils
73 endif
75 ifeq ($(BR2_PACKAGE_BINUTILS),y)
76 RPM_DEPENDENCIES += binutils
77 endif
79 # RPM, when using NLS, requires GNU gettext's _nl_msg_cat_cntr, which is not
80 # provided in musl.
81 ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
82 RPM_CONF_OPTS += --disable-nls
83 endif
85 # ac_cv_prog_cc_c99: RPM uses non-standard GCC extensions (ex. `asm`).
86 RPM_CONF_ENV = \
87 ac_cv_prog_cc_c99='-std=gnu99' \
88 CFLAGS="$(TARGET_CFLAGS) $(RPM_CFLAGS)"
90 $(eval $(autotools-package))