1 ################################################################################
5 ################################################################################
7 SNGREP_VERSION
= v1.4
.2
8 SNGREP_SITE
= $(call github
,irontec
,sngrep
,$(SNGREP_VERSION
))
9 SNGREP_LICENSE
= GPLv3
+
10 SNGREP_LICENSE_FILES
= LICENSE
11 SNGREP_AUTORECONF
= YES
12 SNGREP_DEPENDENCIES
= libpcap ncurses host-pkgconf
15 $(if
$(BR2_STATIC_LIBS
),LIBS
="`$(STAGING_DIR)/usr/bin/pcap-config --static --libs`")
17 # our ncurses wchar support is not properly detected
18 SNGREP_CONF_OPTS
+= --disable-unicode
20 # openssl and gnutls can't be enabled at the same time.
21 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
22 SNGREP_DEPENDENCIES
+= openssl
23 SNGREP_CONF_OPTS
+= --with-openssl
--without-gnutls
24 # gnutls support also requires libgcrypt
25 else ifeq ($(BR2_PACKAGE_GNUTLS
)$(BR2_PACKAGE_LIBGCRYPT
),yy
)
26 SNGREP_DEPENDENCIES
+= gnutls
27 SNGREP_CONF_OPTS
+= --with-gnutls
--without-openssl
29 SNGREP_CONF_OPTS
+= --without-gnutls
--without-openssl
32 ifeq ($(BR2_PACKAGE_PCRE
),y
)
33 SNGREP_DEPENDENCIES
+= pcre
34 SNGREP_CONF_OPTS
+= --with-pcre
36 SNGREP_CONF_OPTS
+= --without-pcre
39 $(eval
$(autotools-package
))