python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / tiff / tiff.mk
blobffb1a425cbea925a656abde5d22f6eff53726b2b
1 ################################################################################
3 # tiff
5 ################################################################################
7 TIFF_VERSION = 4.0.7
8 TIFF_SITE = http://download.osgeo.org/libtiff
9 TIFF_LICENSE = tiff license
10 TIFF_LICENSE_FILES = COPYRIGHT
11 TIFF_INSTALL_STAGING = YES
12 TIFF_CONF_OPTS = \
13 --disable-cxx \
14 --without-x \
16 TIFF_DEPENDENCIES = host-pkgconf
18 HOST_TIFF_CONF_OPTS = \
19 --disable-cxx \
20 --without-x \
21 --disable-zlib \
22 --disable-lzma \
23 --disable-jpeg
24 HOST_TIFF_DEPENDENCIES = host-pkgconf
26 ifneq ($(BR2_PACKAGE_TIFF_CCITT),y)
27 TIFF_CONF_OPTS += --disable-ccitt
28 endif
30 ifneq ($(BR2_PACKAGE_TIFF_PACKBITS),y)
31 TIFF_CONF_OPTS += --disable-packbits
32 endif
34 ifneq ($(BR2_PACKAGE_TIFF_LZW),y)
35 TIFF_CONF_OPTS += --disable-lzw
36 endif
38 ifneq ($(BR2_PACKAGE_TIFF_THUNDER),y)
39 TIFF_CONF_OPTS += --disable-thunder
40 endif
42 ifneq ($(BR2_PACKAGE_TIFF_NEXT),y)
43 TIFF_CONF_OPTS += --disable-next
44 endif
46 ifneq ($(BR2_PACKAGE_TIFF_LOGLUV),y)
47 TIFF_CONF_OPTS += --disable-logluv
48 endif
50 ifneq ($(BR2_PACKAGE_TIFF_MDI),y)
51 TIFF_CONF_OPTS += --disable-mdi
52 endif
54 ifneq ($(BR2_PACKAGE_TIFF_ZLIB),y)
55 TIFF_CONF_OPTS += --disable-zlib
56 else
57 TIFF_DEPENDENCIES += zlib
58 endif
60 ifneq ($(BR2_PACKAGE_TIFF_XZ),y)
61 TIFF_CONF_OPTS += --disable-lzma
62 else
63 TIFF_DEPENDENCIES += xz
64 endif
66 ifneq ($(BR2_PACKAGE_TIFF_PIXARLOG),y)
67 TIFF_CONF_OPTS += --disable-pixarlog
68 endif
70 ifneq ($(BR2_PACKAGE_TIFF_JPEG),y)
71 TIFF_CONF_OPTS += --disable-jpeg
72 else
73 TIFF_DEPENDENCIES += jpeg
74 endif
76 ifneq ($(BR2_PACKAGE_TIFF_OLD_JPEG),y)
77 TIFF_CONF_OPTS += --disable-old-jpeg
78 endif
80 ifneq ($(BR2_PACKAGE_TIFF_JBIG),y)
81 TIFF_CONF_OPTS += --disable-jbig
82 endif
84 TIFF_SUBDIRS = port libtiff
85 ifeq ($(BR2_PACKAGE_TIFF_UTILITIES),y)
86 TIFF_SUBDIRS += tools
87 endif
89 TIFF_MAKE = $(MAKE) SUBDIRS="$(TIFF_SUBDIRS)"
91 $(eval $(autotools-package))
92 $(eval $(host-autotools-package))