1 ################################################################################
5 ################################################################################
8 TIFF_SITE
= http
://download.osgeo.org
/libtiff
9 TIFF_LICENSE
= tiff license
10 TIFF_LICENSE_FILES
= COPYRIGHT
11 TIFF_INSTALL_STAGING
= YES
16 TIFF_DEPENDENCIES
= host-pkgconf
18 HOST_TIFF_CONF_OPTS
= \
24 HOST_TIFF_DEPENDENCIES
= host-pkgconf
26 ifneq ($(BR2_PACKAGE_TIFF_CCITT
),y
)
27 TIFF_CONF_OPTS
+= --disable-ccitt
30 ifneq ($(BR2_PACKAGE_TIFF_PACKBITS
),y
)
31 TIFF_CONF_OPTS
+= --disable-packbits
34 ifneq ($(BR2_PACKAGE_TIFF_LZW
),y
)
35 TIFF_CONF_OPTS
+= --disable-lzw
38 ifneq ($(BR2_PACKAGE_TIFF_THUNDER
),y
)
39 TIFF_CONF_OPTS
+= --disable-thunder
42 ifneq ($(BR2_PACKAGE_TIFF_NEXT
),y
)
43 TIFF_CONF_OPTS
+= --disable-next
46 ifneq ($(BR2_PACKAGE_TIFF_LOGLUV
),y
)
47 TIFF_CONF_OPTS
+= --disable-logluv
50 ifneq ($(BR2_PACKAGE_TIFF_MDI
),y
)
51 TIFF_CONF_OPTS
+= --disable-mdi
54 ifneq ($(BR2_PACKAGE_TIFF_ZLIB
),y
)
55 TIFF_CONF_OPTS
+= --disable-zlib
57 TIFF_DEPENDENCIES
+= zlib
60 ifneq ($(BR2_PACKAGE_TIFF_XZ
),y
)
61 TIFF_CONF_OPTS
+= --disable-lzma
63 TIFF_DEPENDENCIES
+= xz
66 ifneq ($(BR2_PACKAGE_TIFF_PIXARLOG
),y
)
67 TIFF_CONF_OPTS
+= --disable-pixarlog
70 ifneq ($(BR2_PACKAGE_TIFF_JPEG
),y
)
71 TIFF_CONF_OPTS
+= --disable-jpeg
73 TIFF_DEPENDENCIES
+= jpeg
76 ifneq ($(BR2_PACKAGE_TIFF_OLD_JPEG
),y
)
77 TIFF_CONF_OPTS
+= --disable-old-jpeg
80 ifneq ($(BR2_PACKAGE_TIFF_JBIG
),y
)
81 TIFF_CONF_OPTS
+= --disable-jbig
84 TIFF_SUBDIRS
= port libtiff
85 ifeq ($(BR2_PACKAGE_TIFF_UTILITIES
),y
)
89 TIFF_MAKE
= $(MAKE
) SUBDIRS
="$(TIFF_SUBDIRS)"
91 $(eval
$(autotools-package
))
92 $(eval
$(host-autotools-package
))