1 ################################################################################
5 ################################################################################
7 # No releases or tags yet. Use the latest commit ID from master branch.
8 TSTOOLS_VERSION
= 08f6be304040e7b84760ac3920bcff4a563b6cd2
9 TSTOOLS_SITE
= $(call github
,kynesim
,tstools
,$(TSTOOLS_VERSION
))
10 # tstools upstream doesn't contain any license file so far. See:
11 # https://github.com/kynesim/tstools/issues/32
12 TSTOOLS_LICENSE
= MPLv1.1
13 TSTOOLS_LICENSE_FILES
=
15 define TSTOOLS_BUILD_CMDS
16 $(TARGET_CONFIGURE_OPTS
) LD
="$(TARGET_CC)" $(TARGET_MAKE_ENV
) \
20 define TSTOOLS_INSTALL_TARGET_CMDS
21 $(TARGET_CONFIGURE_OPTS
) $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
) \
22 DESTDIR
=$(TARGET_DIR
) install
25 $(eval
$(generic-package
))