python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / vde2 / vde2.mk
blob3bbfd5f5ca2806148a699e48ca0fb8c41e759513
1 ################################################################################
3 # vde2
5 ################################################################################
7 VDE2_VERSION = 2.3.2
8 VDE2_SOURCE = vde2-$(VDE2_VERSION).tar.bz2
9 VDE2_SITE = http://downloads.sourceforge.net/project/vde/vde2/$(VDE2_VERSION)
10 VDE2_LICENSE = GPLv2+, LGPLv2.1+, BSD-3c
11 VDE2_LICENSE_FILES = COPYING COPYING.libvdeplug COPYING.slirpvde
12 VDE2_INSTALL_STAGING = YES
14 # We touch configure.ac, so we need to autoreconf
15 VDE2_AUTORECONF = YES
17 # Reasons for enabling/disabling stuff:
18 # - tuntap is enabled in the hope we're using a recent-enough toolchain
19 # that does have if_tun.h (virtually everything these days)
20 # - kvde_switch is disabled because it requires a patched kernel
21 # - cryptcab is disabled to not depend on openSSL
22 # - python is disabled to not depend on Python
23 # - pcap is disabled to not depend on libpcap
24 # - profiling is disabled because we do not want to debug/profile
26 # Note: disabled features can be added with corresponding dependencies
27 # in future commits.
28 VDE2_CONF_OPTS = \
29 --disable-cryptcab \
30 --disable-experimental \
31 --disable-kernel-switch \
32 --disable-pcap \
33 --disable-profile \
34 --disable-python \
35 --enable-tuntap
37 # Package does not build in parallel due to improper make rules
38 VDE2_MAKE = $(MAKE1)
40 HOST_VDE2_CONF_OPTS = \
41 --disable-cryptcab \
42 --disable-experimental \
43 --disable-kernel-switch \
44 --disable-pcap \
45 --disable-profile \
46 --disable-python \
47 --enable-tuntap
49 HOST_VDE2_MAKE = $(MAKE1)
51 $(eval $(autotools-package))
52 $(eval $(host-autotools-package))