1 ################################################################################
5 ################################################################################
8 VDE2_SOURCE
= vde2-
$(VDE2_VERSION
).
tar.bz2
9 VDE2_SITE
= http
://downloads.sourceforge.net
/project
/vde
/vde2
/$(VDE2_VERSION
)
10 VDE2_LICENSE
= GPLv2
+, LGPLv2.1
+, BSD-3c
11 VDE2_LICENSE_FILES
= COPYING COPYING.libvdeplug COPYING.slirpvde
12 VDE2_INSTALL_STAGING
= YES
14 # We touch configure.ac, so we need to autoreconf
17 # Reasons for enabling/disabling stuff:
18 # - tuntap is enabled in the hope we're using a recent-enough toolchain
19 # that does have if_tun.h (virtually everything these days)
20 # - kvde_switch is disabled because it requires a patched kernel
21 # - cryptcab is disabled to not depend on openSSL
22 # - python is disabled to not depend on Python
23 # - pcap is disabled to not depend on libpcap
24 # - profiling is disabled because we do not want to debug/profile
26 # Note: disabled features can be added with corresponding dependencies
30 --disable-experimental \
31 --disable-kernel-switch \
37 # Package does not build in parallel due to improper make rules
40 HOST_VDE2_CONF_OPTS
= \
42 --disable-experimental \
43 --disable-kernel-switch \
49 HOST_VDE2_MAKE
= $(MAKE1
)
51 $(eval
$(autotools-package
))
52 $(eval
$(host-autotools-package
))