python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / vnstat / vnstat.mk
blob576f240a28021b8bee486a82d1469fd7b67517ed
1 ################################################################################
3 # vnstat
5 ################################################################################
7 VNSTAT_VERSION = 1.15
8 VNSTAT_SITE = http://humdi.net/vnstat
9 VNSTAT_LICENSE = GPLv2
10 VNSTAT_LICENSE_FILES = COPYING
11 VNSTAT_DEPENDENCIES = host-pkgconf
12 # We're patching configure.ac, so we need to autoreconf
13 VNSTAT_AUTORECONF = YES
15 ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
16 VNSTAT_DEPENDENCIES += gd
17 VNSTAT_CONF_OPTS = --enable-image-output
18 else
19 VNSTAT_CONF_OPTS = --disable-image-output
20 endif
22 # vnStat declares an 'install-data-hook' rule that tries to run
23 # 'vnstat --showconfig' on the host to generate a default config file.
24 # That obviously doesn't work when cross-compiling, so avoid it
25 # entirely.
26 VNSTAT_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-exec
28 $(eval $(autotools-package))