1 ################################################################################
5 ################################################################################
7 VO_AACENC_VERSION
= 0.1.3
8 VO_AACENC_SITE
= http
://downloads.sourceforge.net
/project
/opencore-amr
/vo-aacenc
9 VO_AACENC_LICENSE
= Apache-2.0
10 VO_AACENC_LICENSE_FILES
= COPYING
11 VO_AACENC_INSTALL_STAGING
= YES
13 VO_AACENC_CFLAGS
= $(TARGET_CFLAGS
)
15 # arm specific asm optimizations
18 ifeq ($(BR2_ARM_CPU_HAS_ARM
),y
)
19 # vo-aacenc has ARM assembly code that cannot be compiled in Thumb2
20 # mode, so we must force the traditional ARM mode.
21 VO_AACENC_CFLAGS
+= -marm
23 ifeq ($(BR2_ARM_CPU_HAS_NEON
),y
)
24 VO_AACENC_CONF_OPTS
+= --enable-armv7neon
25 # mfpu=neon needed to assemble neon code
26 VO_AACENC_CFLAGS
+= -mfpu
=neon
28 VO_AACENC_CONF_OPTS
+= --disable-armv7neon
30 ifeq ($(BR2_ARM_CPU_ARMV4
),)
31 VO_AACENC_CONF_OPTS
+= --enable-armv5e
33 VO_AACENC_CONF_OPTS
+= --disable-armv5e
39 VO_AACENC_CONF_OPTS
+= --disable-armv7neon
--disable-armv5e
43 VO_AACENC_CONF_ENV
= \
44 CFLAGS
="$(VO_AACENC_CFLAGS)"
46 $(eval
$(autotools-package
))