python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / vpnc / vpnc.mk
blob282a42250816026e3a7b91d74ced03ca5afa81eb
1 ################################################################################
3 # vpnc
5 ################################################################################
7 VPNC_VERSION = b1243d29e0c00312ead038b04a2cf5e2fa31d740
8 VPNC_SITE = $(call github,ndpgroup,vpnc,$(VPNC_VERSION))
9 VPNC_LICENSE = GPLv2+
10 VPNC_LICENSE_FILES = COPYING
12 VPNC_DEPENDENCIES = libgcrypt libgpg-error gnutls host-pkgconf
14 define VPNC_BUILD_CMDS
15 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
16 $(TARGET_CONFIGURE_OPTS) \
17 LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config \
18 VERSION=$(VPNC_VERSION) MANS=
19 endef
21 define VPNC_INSTALL_TARGET_CMDS
22 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install $(TARGET_CONFIGURE_OPTS) \
23 VERSION=$(VPNC_VERSION) MANS= \
24 DESTDIR="$(TARGET_DIR)" PREFIX=/usr
25 endef
27 $(eval $(generic-package))