python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / wavpack / wavpack.mk
bloba61350623486e3421bb56cca969c0480a7e27508
1 ################################################################################
3 # wavpack
5 ################################################################################
7 WAVPACK_VERSION = 5.1.0
8 WAVPACK_SITE = http://www.wavpack.com
9 WAVPACK_SOURCE = wavpack-$(WAVPACK_VERSION).tar.bz2
10 WAVPACK_INSTALL_STAGING = YES
11 WAVPACK_DEPENDENCIES = $(if $(BR2_ENABLE_LOCALE),,libiconv)
12 WAVPACK_LICENSE = BSD-3c
13 WAVPACK_LICENSE_FILES = COPYING
15 # Fetch patch from upstream to remove wchar dependency
16 WAVPACK_PATCH = https://github.com/dbry/WavPack/commit/876fc3f3907e871d0938ac6c8c5252f5f31abd1f.patch
18 ifeq ($(BR2_PACKAGE_LIBICONV),y)
19 WAVPACK_CONF_OPTS += LIBS=-liconv
20 endif
22 # WavPack "autodetects" CPU type to enable ASM code. However, the assembly code
23 # for ARM is written for ARMv7 only and building WavPack for an ARM-non-v7
24 # architecture will fail. We explicitly enable ASM for the supported
25 # architectures x86, x64 and ARMv7 and disable it for all others.
26 ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_ARM_CPU_ARMV7A),y)
27 WAVPACK_CONF_OPTS += --enable-asm
28 else
29 WAVPACK_CONF_OPTS += --disable-asm
30 endif
32 $(eval $(autotools-package))