python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / weston / weston.mk
bloba6d9faa1b8b1906c5408c77066be8310eeb92b23
1 ################################################################################
3 # weston
5 ################################################################################
7 WESTON_VERSION = 2.0.0
8 WESTON_SITE = http://wayland.freedesktop.org/releases
9 WESTON_SOURCE = weston-$(WESTON_VERSION).tar.xz
10 WESTON_LICENSE = MIT
11 WESTON_LICENSE_FILES = COPYING
13 WESTON_DEPENDENCIES = host-pkgconf wayland wayland-protocols \
14 libxkbcommon pixman libpng jpeg mtdev udev cairo libinput \
15 $(if $(BR2_PACKAGE_WEBP),webp)
17 WESTON_CONF_OPTS = \
18 --with-dtddir=$(STAGING_DIR)/usr/share/wayland \
19 --disable-headless-compositor \
20 --disable-colord \
21 --disable-devdocs \
22 --disable-setuid-install
24 WESTON_MAKE_OPTS = \
25 WAYLAND_PROTOCOLS_DATADIR=$(STAGING_DIR)/usr/share/wayland-protocols
27 # Uses VIDIOC_EXPBUF, only available from 3.8+
28 ifeq ($(BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_8),)
29 WESTON_CONF_OPTS += --disable-simple-dmabuf-v4l-client
30 endif
32 ifeq ($(BR2_PACKAGE_DBUS),y)
33 WESTON_CONF_OPTS += --enable-dbus
34 WESTON_DEPENDENCIES += dbus
35 else
36 WESTON_CONF_OPTS += --disable-dbus
37 endif
39 # weston-launch must be u+s root in order to work properly
40 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
41 define WESTON_PERMISSIONS
42 /usr/bin/weston-launch f 4755 0 0 - - - - -
43 endef
44 define WESTON_USERS
45 - - weston-launch -1 - - - - Weston launcher group
46 endef
47 WESTON_CONF_OPTS += --enable-weston-launch
48 WESTON_DEPENDENCIES += linux-pam
49 else
50 WESTON_CONF_OPTS += --disable-weston-launch
51 endif
53 # Needs wayland-egl, which normally only mesa provides
54 ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL)$(BR2_PACKAGE_MESA3D_OPENGL_ES),yy)
55 WESTON_CONF_OPTS += --enable-egl
56 WESTON_DEPENDENCIES += libegl
57 else
58 WESTON_CONF_OPTS += \
59 --disable-egl \
60 --disable-simple-egl-clients
61 endif
63 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
64 WESTON_DEPENDENCIES += libunwind
65 else
66 WESTON_CONF_OPTS += --disable-libunwind
67 endif
69 ifeq ($(BR2_PACKAGE_WESTON_RDP),y)
70 WESTON_DEPENDENCIES += freerdp
71 WESTON_CONF_OPTS += --enable-rdp-compositor
72 else
73 WESTON_CONF_OPTS += --disable-rdp-compositor
74 endif
76 ifeq ($(BR2_PACKAGE_WESTON_FBDEV),y)
77 WESTON_CONF_OPTS += \
78 --enable-fbdev-compositor \
79 WESTON_NATIVE_BACKEND=fbdev-backend.so
80 else
81 WESTON_CONF_OPTS += --disable-fbdev-compositor
82 endif
84 ifeq ($(BR2_PACKAGE_WESTON_DRM),y)
85 WESTON_CONF_OPTS += \
86 --enable-drm-compositor \
87 WESTON_NATIVE_BACKEND=drm-backend.so
88 WESTON_DEPENDENCIES += libdrm
89 else
90 WESTON_CONF_OPTS += --disable-drm-compositor
91 endif
93 ifeq ($(BR2_PACKAGE_WESTON_X11),y)
94 WESTON_CONF_OPTS += \
95 --enable-x11-compositor \
96 WESTON_NATIVE_BACKEND=x11-backend.so
97 WESTON_DEPENDENCIES += libxcb xlib_libX11
98 else
99 WESTON_CONF_OPTS += --disable-x11-compositor
100 endif
102 ifeq ($(BR2_PACKAGE_WESTON_XWAYLAND),y)
103 WESTON_CONF_OPTS += --enable-xwayland
104 WESTON_DEPENDENCIES += cairo libepoxy libxcb xlib_libX11 xlib_libXcursor
105 else
106 WESTON_CONF_OPTS += --disable-xwayland
107 endif
109 ifeq ($(BR2_PACKAGE_LIBVA),y)
110 WESTON_CONF_OPTS += --enable-vaapi-recorder
111 WESTON_DEPENDENCIES += libva
112 else
113 WESTON_CONF_OPTS += --disable-vaapi-recorder
114 endif
116 ifeq ($(BR2_PACKAGE_LCMS2),y)
117 WESTON_CONF_OPTS += --enable-lcms
118 WESTON_DEPENDENCIES += lcms2
119 else
120 WESTON_CONF_OPTS += --disable-lcms
121 endif
123 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
124 WESTON_CONF_OPTS += --enable-systemd-login --enable-systemd-notify
125 WESTON_DEPENDENCIES += systemd
126 else
127 WESTON_CONF_OPTS += --disable-systemd-login --disable-systemd-notify
128 endif
130 ifeq ($(BR2_PACKAGE_LIBXML2),y)
131 WESTON_CONF_OPTS += --enable-junit-xml
132 WESTON_DEPENDENCIES += libxml2
133 else
134 WESTON_CONF_OPTS += --disable-junit-xml
135 endif
137 ifeq ($(BR2_PACKAGE_WESTON_DEMO_CLIENTS),y)
138 WESTON_CONF_OPTS += --enable-demo-clients-install
139 else
140 WESTON_CONF_OPTS += --disable-demo-clients-install
141 endif
143 $(eval $(autotools-package))