1 ################################################################################
5 ################################################################################
7 XFSPROGS_VERSION
= 4.8.0
8 XFSPROGS_SITE
= $(BR2_KERNEL_MIRROR
)/linux
/utils
/fs
/xfs
/xfsprogs
9 XFSPROGS_SOURCE
= xfsprogs-
$(XFSPROGS_VERSION
).
tar.xz
11 XFSPROGS_DEPENDENCIES
= util-linux
13 XFSPROGS_CONF_ENV
= ac_cv_header_aio_h
=yes ac_cv_lib_rt_lio_listio
=yes
14 XFSPROGS_CONF_OPTS
= \
21 # xfsprogs links some of its programs to libs from util-linux, which use
22 # i18n functions. For shared-only builds, that's automatically pulled in.
23 # Static builds need some help, though...
25 # No need to depend on gettext in this case: xfsprogs does not use it for
26 # itself; util-linux does need it and has it in its own dependencies.
28 # xfsprogs' buildsystem uses hand-made Makefiles, not automake, and they
29 # do not use the LIBS variable set by configure. So we use EXTRALIBS that
30 # is added by our patch.
32 # It is not needed to propagate the EXTRALIBS to the install step.
33 ifeq ($(BR2_STATIC_LIBS
)$(BR2_SHARED_STATIC_LIBS
)$(BR2_NEEDS_GETTEXT_IF_LOCALE
),yy
)
34 XFSPROGS_CONF_OPTS
+= LIBS
=-lintl
35 XFSPROGS_MAKE_OPTS
= EXTRALIBS
=-lintl
38 XFSPROGS_INSTALL_TARGET_OPTS
= DIST_ROOT
=$(TARGET_DIR
) install
40 $(eval
$(autotools-package
))