1 ################################################################################
5 ################################################################################
8 ZNC_SITE
= http
://znc.in
/releases
9 ZNC_LICENSE
= Apache-2.0
10 ZNC_LICENSE_FILES
= LICENSE
11 ZNC_DEPENDENCIES
= host-pkgconf
12 ZNC_CONF_OPTS
= --disable-perl
14 ifeq ($(BR2_PACKAGE_ICU
),y
)
15 ZNC_DEPENDENCIES
+= icu
16 ZNC_CONF_OPTS
+= --enable-charset
18 ZNC_CONF_OPTS
+= --disable-charset
21 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
22 ZNC_DEPENDENCIES
+= openssl
23 ZNC_CONF_OPTS
+= --enable-openssl
25 ZNC_CONF_OPTS
+= --disable-openssl
28 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
29 ZNC_DEPENDENCIES
+= zlib
30 ZNC_CONF_OPTS
+= --enable-zlib
32 ZNC_CONF_OPTS
+= --disable-zlib
35 ifeq ($(BR2_PACKAGE_PYTHON3
),y
)
36 ZNC_DEPENDENCIES
+= python3 host-swig
37 ZNC_CONF_OPTS
+= --enable-python
=python3
39 ZNC_CONF_OPTS
+= --disable-python
42 $(eval
$(autotools-package
))