libinput: bump version to 1.6.0
[buildroot-gz.git] / package / libinput / libinput.mk
blob52aca9acfd3985f0785bc58fcd2af66785d01c34
1 ################################################################################
3 # libinput
5 ################################################################################
7 LIBINPUT_VERSION = 1.6.0
8 LIBINPUT_SOURCE = libinput-$(LIBINPUT_VERSION).tar.xz
9 LIBINPUT_SITE = http://www.freedesktop.org/software/libinput
10 LIBINPUT_DEPENDENCIES = host-pkgconf libevdev mtdev udev
11 LIBINPUT_INSTALL_STAGING = YES
12 LIBINPUT_LICENSE = MIT
13 LIBINPUT_LICENSE_FILES = COPYING
14 # Tests need fork, so just disable them everywhere.
15 LIBINPUT_CONF_OPTS = --disable-tests --disable-libwacom
17 ifeq ($(BR2_PACKAGE_LIBGTK3),y)
18 LIBINPUT_CONF_OPTS += --enable-event-gui
19 LIBINPUT_DEPENDENCIES += libgtk3
20 else
21 LIBINPUT_CONF_OPTS += --disable-event-gui
22 endif
24 $(eval $(autotools-package))