perl-cross: bump to version 1.1.4
[buildroot-gz.git] / package / gnutls / gnutls.mk
blob932c0fab0ccd408590ed9d8956b39e55d515b0c1
1 ################################################################################
3 # gnutls
5 ################################################################################
7 GNUTLS_VERSION_MAJOR = 3.5
8 GNUTLS_VERSION = $(GNUTLS_VERSION_MAJOR).9
9 GNUTLS_SOURCE = gnutls-$(GNUTLS_VERSION).tar.xz
10 GNUTLS_SITE = ftp://ftp.gnutls.org/gcrypt/gnutls/v$(GNUTLS_VERSION_MAJOR)
11 GNUTLS_LICENSE = LGPLv2.1+ (core library), GPLv3+ (gnutls-openssl library)
12 GNUTLS_LICENSE_FILES = doc/COPYING doc/COPYING.LESSER
13 GNUTLS_DEPENDENCIES = host-pkgconf libunistring libtasn1 nettle pcre
14 GNUTLS_CONF_OPTS = \
15 --disable-doc \
16 --disable-guile \
17 --disable-libdane \
18 --disable-rpath \
19 --enable-local-libopts \
20 --enable-openssl-compatibility \
21 --with-libnettle-prefix=$(STAGING_DIR)/usr \
22 --with-libunistring-prefix=$(STAGING_DIR)/usr \
23 --with-librt-prefix=$(STAGING_DIR) \
24 --without-tpm \
25 $(if $(BR2_PACKAGE_GNUTLS_TOOLS),--enable-tools,--disable-tools)
26 GNUTLS_CONF_ENV = gl_cv_socket_ipv6=yes \
27 ac_cv_header_wchar_h=$(if $(BR2_USE_WCHAR),yes,no) \
28 gt_cv_c_wchar_t=$(if $(BR2_USE_WCHAR),yes,no) \
29 gt_cv_c_wint_t=$(if $(BR2_USE_WCHAR),yes,no) \
30 gl_cv_func_gettimeofday_clobber=no
31 GNUTLS_INSTALL_STAGING = YES
33 # libpthread and libz autodetection poison the linkpath
34 GNUTLS_CONF_OPTS += $(if $(BR2_TOOLCHAIN_HAS_THREADS),--with-libpthread-prefix=$(STAGING_DIR)/usr)
35 GNUTLS_CONF_OPTS += $(if $(BR2_PACKAGE_ZLIB),--with-libz-prefix=$(STAGING_DIR)/usr)
37 # gnutls needs libregex, but pcre can be used too
38 # The check isn't cross-compile friendly
39 GNUTLS_CONF_ENV += libopts_cv_with_libregex=yes
40 GNUTLS_CONF_OPTS += \
41 --with-regex-header=pcreposix.h \
42 --with-libregex-cflags="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --cflags`" \
43 --with-libregex-libs="`$(PKG_CONFIG_HOST_BINARY) libpcreposix --libs`"
45 # Consider crywrap as part of tools because it needs WCHAR, and it's so too
46 ifeq ($(BR2_PACKAGE_GNUTLS_TOOLS),)
47 GNUTLS_CONF_OPTS += --disable-crywrap
48 endif
50 # Prerequisite for crywrap
51 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
52 GNUTLS_CONF_ENV += LIBS="-largp"
53 GNUTLS_DEPENDENCIES += argp-standalone
54 endif
56 # libidn support for nommu must exclude the crywrap wrapper (uses fork)
57 GNUTLS_CONF_OPTS += $(if $(BR2_USE_MMU),,--disable-crywrap)
59 ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
60 GNUTLS_CONF_OPTS += --enable-cryptodev
61 GNUTLS_DEPENDENCIES += cryptodev-linux
62 endif
64 ifeq ($(BR2_PACKAGE_LIBIDN),y)
65 GNUTLS_CONF_OPTS += --with-idn
66 GNUTLS_DEPENDENCIES += libidn
67 else
68 GNUTLS_CONF_OPTS += --without-idn
69 endif
71 ifeq ($(BR2_PACKAGE_P11_KIT),y)
72 GNUTLS_CONF_OPTS += --with-p11-kit
73 GNUTLS_DEPENDENCIES += p11-kit
74 else
75 GNUTLS_CONF_OPTS += --without-p11-kit
76 endif
78 ifeq ($(BR2_PACKAGE_ZLIB),y)
79 GNUTLS_CONF_OPTS += --with-zlib
80 GNUTLS_DEPENDENCIES += zlib
81 else
82 GNUTLS_CONF_OPTS += --without-zlib
83 endif
85 $(eval $(autotools-package))