1 ################################################################################
5 ################################################################################
7 GUTENPRINT_VERSION_MAJOR
= 5.2
8 GUTENPRINT_VERSION
= $(GUTENPRINT_VERSION_MAJOR
).11
9 GUTENPRINT_SITE
= http
://downloads.sourceforge.net
/project
/gimp-print
/gutenprint-
$(GUTENPRINT_VERSION_MAJOR
)/$(GUTENPRINT_VERSION
)
10 GUTENPRINT_SOURCE
= gutenprint-
$(GUTENPRINT_VERSION
).
tar.bz2
11 GUTENPRINT_LICENSE
= GPLv2
+
12 GUTENPRINT_LICENSE_FILES
= COPYING
14 # Needed, as we touch Makefile.am and configure.ac
15 GUTENPRINT_AUTORECONF
= YES
17 GUTENPRINT_DEPENDENCIES
= \
19 $(if
$(BR2_PACKAGE_LIBICONV
),libiconv
) \
20 $(if
$(BR2_PACKAGE_LIBUSB
),libusb
)
22 # host-gutenprint is needed to generate XML as part of compilation
23 # the program that generates the xml also links against libgutenprint
24 # so we need to build both a host package and a target package
25 GUTENPRINT_DEPENDENCIES
+= host-gutenprint
27 GUTENPRINT_CONF_ENV
= \
28 ac_cv_path_CUPS_CONFIG
=$(STAGING_DIR
)/usr
/bin
/cups-config \
29 ac_cv_path_IJS_CONFIG
=""
31 GUTENPRINT_CONF_OPTS
= \
32 --disable-libgutenprintui2 \
40 --disable-testpattern \
42 --with-sysroot
="$(STAGING_DIR)" \
45 # USE_PREGEN_XMLI18N_TMP_H is added by our patch
46 GUTENPRINT_MAKE_ENV
= BR2_USE_PREGEN_XMLI18N_TMP_H
=$(HOST_DIR
)/usr
/include/xmli18n-tmp.h
48 HOST_GUTENPRINT_DEPENDENCIES
= host-pkgconf
49 # The host-gutenprint shall create the required header
50 HOST_GUTENPRINT_MAKE_ENV
=
52 # Even with --without-cups, gutenprint will still add the output of
53 # cups-config --cflags / --ldflags to it's compiler/linker flags if
55 # Notice: Because of the configure logic, it needs to be set to the
56 # empty string to to disable this, not just to /bin/false like elsewhere.
57 HOST_GUTENPRINT_CONF_ENV
= ac_cv_path_CUPS_CONFIG
=''
59 HOST_GUTENPRINT_CONF_OPTS
= \
60 --disable-libgutenprintui2 \
70 --disable-testpattern \
73 # Needed by autoreconf
74 define GUTENPRINT_CREATE_M4_DIR
75 mkdir
-p
$(@D
)/m4local
77 GUTENPRINT_POST_PATCH_HOOKS
+= GUTENPRINT_CREATE_M4_DIR
78 HOST_GUTENPRINT_POST_PATCH_HOOKS
+= GUTENPRINT_CREATE_M4_DIR
80 define HOST_GUTENPRINT_POST_BUILD_INSTAL_TMP_HEADER
81 cp
$(@D
)/src
/xml
/xmli18n-tmp.h
$(HOST_DIR
)/usr
/include
83 HOST_GUTENPRINT_POST_BUILD_HOOKS
+= HOST_GUTENPRINT_POST_BUILD_INSTAL_TMP_HEADER
85 define GUTENPRINT_POST_INSTALL_TARGET_FIXUP
86 mkdir
-p
$(TARGET_DIR
)/usr
/share
/gutenprint
/5.2
87 cp
-rf
$(HOST_DIR
)/usr
/share
/gutenprint
/5.2/xml
$(TARGET_DIR
)/usr
/share
/gutenprint
/5.2
89 GUTENPRINT_POST_INSTALL_TARGET_HOOKS
+= GUTENPRINT_POST_INSTALL_TARGET_FIXUP
91 $(eval
$(autotools-package
))
92 $(eval
$(host-autotools-package
))