package/logrotate: update upstream site in Config.in help
[buildroot-gz.git] / package / gutenprint / gutenprint.mk
blob8ee2406abbbad34cd6f6131c0a3c793bc491f237
1 ################################################################################
3 # gutenprint
5 ################################################################################
7 GUTENPRINT_VERSION_MAJOR = 5.2
8 GUTENPRINT_VERSION = $(GUTENPRINT_VERSION_MAJOR).11
9 GUTENPRINT_SITE = http://downloads.sourceforge.net/project/gimp-print/gutenprint-$(GUTENPRINT_VERSION_MAJOR)/$(GUTENPRINT_VERSION)
10 GUTENPRINT_SOURCE = gutenprint-$(GUTENPRINT_VERSION).tar.bz2
11 GUTENPRINT_LICENSE = GPLv2+
12 GUTENPRINT_LICENSE_FILES = COPYING
14 # Needed, as we touch Makefile.am and configure.ac
15 GUTENPRINT_AUTORECONF = YES
17 GUTENPRINT_DEPENDENCIES = \
18 cups host-pkgconf \
19 $(if $(BR2_PACKAGE_LIBICONV),libiconv) \
20 $(if $(BR2_PACKAGE_LIBUSB),libusb)
22 # host-gutenprint is needed to generate XML as part of compilation
23 # the program that generates the xml also links against libgutenprint
24 # so we need to build both a host package and a target package
25 GUTENPRINT_DEPENDENCIES += host-gutenprint
27 GUTENPRINT_CONF_ENV = \
28 ac_cv_path_CUPS_CONFIG=$(STAGING_DIR)/usr/bin/cups-config \
29 ac_cv_path_IJS_CONFIG=""
31 GUTENPRINT_CONF_OPTS = \
32 --disable-libgutenprintui2 \
33 --disable-samples \
34 --without-doc \
35 --without-gimp2 \
36 --without-foomatic \
37 --without-foomatic3 \
38 --disable-escputil \
39 --disable-test \
40 --disable-testpattern \
41 --with-cups="/usr" \
42 --with-sysroot="$(STAGING_DIR)" \
43 --disable-cups-ppds
45 # USE_PREGEN_XMLI18N_TMP_H is added by our patch
46 GUTENPRINT_MAKE_ENV = BR2_USE_PREGEN_XMLI18N_TMP_H=$(HOST_DIR)/usr/include/xmli18n-tmp.h
48 HOST_GUTENPRINT_DEPENDENCIES = host-pkgconf
49 # The host-gutenprint shall create the required header
50 HOST_GUTENPRINT_MAKE_ENV =
52 # Even with --without-cups, gutenprint will still add the output of
53 # cups-config --cflags / --ldflags to it's compiler/linker flags if
54 # available on host.
55 # Notice: Because of the configure logic, it needs to be set to the
56 # empty string to to disable this, not just to /bin/false like elsewhere.
57 HOST_GUTENPRINT_CONF_ENV = ac_cv_path_CUPS_CONFIG=''
59 HOST_GUTENPRINT_CONF_OPTS = \
60 --disable-libgutenprintui2 \
61 --disable-samples \
62 --without-gimp2 \
63 --without-doc \
64 --disable-nls \
65 --disable-nls-macos \
66 --without-foomatic \
67 --without-foomatic3 \
68 --disable-escputil \
69 --disable-test \
70 --disable-testpattern \
71 --without-cups
73 # Needed by autoreconf
74 define GUTENPRINT_CREATE_M4_DIR
75 mkdir -p $(@D)/m4local
76 endef
77 GUTENPRINT_POST_PATCH_HOOKS += GUTENPRINT_CREATE_M4_DIR
78 HOST_GUTENPRINT_POST_PATCH_HOOKS += GUTENPRINT_CREATE_M4_DIR
80 define HOST_GUTENPRINT_POST_BUILD_INSTAL_TMP_HEADER
81 cp $(@D)/src/xml/xmli18n-tmp.h $(HOST_DIR)/usr/include
82 endef
83 HOST_GUTENPRINT_POST_BUILD_HOOKS += HOST_GUTENPRINT_POST_BUILD_INSTAL_TMP_HEADER
85 define GUTENPRINT_POST_INSTALL_TARGET_FIXUP
86 mkdir -p $(TARGET_DIR)/usr/share/gutenprint/5.2
87 cp -rf $(HOST_DIR)/usr/share/gutenprint/5.2/xml $(TARGET_DIR)/usr/share/gutenprint/5.2
88 endef
89 GUTENPRINT_POST_INSTALL_TARGET_HOOKS += GUTENPRINT_POST_INSTALL_TARGET_FIXUP
91 $(eval $(autotools-package))
92 $(eval $(host-autotools-package))