1 ################################################################################
5 ################################################################################
7 PRU_SOFTWARE_SUPPORT_VERSION
= v5.1
.0
8 PRU_SOFTWARE_SUPPORT_SITE
= https
://git.ti.com
/pru-software-support-package
/pru-software-support-package
/archive-tarball
/$(PRU_SOFTWARE_SUPPORT_VERSION
)?
9 PRU_SOFTWARE_SUPPORT_LICENSE
= BSD-3c
, GPLv2
, Public Domain
10 PRU_SOFTWARE_SUPPORT_LICENSE_FILES
= PRU-Package-v5.0
-Manifest.html
11 PRU_SOFTWARE_SUPPORT_DEPENDENCIES
= host-ti-cgt-pru host-pru-software-support
12 HOST_PRU_SOFTWARE_SUPPORT_DEPENDENCIES
= host-ti-cgt-pru
14 define HOST_PRU_SOFTWARE_SUPPORT_BUILD_CMDS
15 $(MAKE
) PRU_CGT
=$(TI_CGT_PRU_INSTALLDIR
) -C
$(@D
)/lib
/src
18 # install this library support alongside PRU toolchain i.e.
19 # everything in TI_CGT_PRU_INSTALLDIR as PRU_CGT
20 define HOST_PRU_SOFTWARE_SUPPORT_INSTALL_CMDS
21 mkdir
-p
$(TI_CGT_PRU_INSTALLDIR
)/usr
/include
22 cp
-dpfr
$(@D
)/include/* $(TI_CGT_PRU_INSTALLDIR
)/usr
/include
23 mkdir
-p
$(TI_CGT_PRU_INSTALLDIR
)/usr
/lib
24 cp
-dpfr
$(@D
)/lib
/src
/*/gen
/*.lib
$(TI_CGT_PRU_INSTALLDIR
)/usr
/lib
/
27 define PRU_SOFTWARE_SUPPORT_BUILD_CMDS
28 $(MAKE
) PRU_CGT
=$(TI_CGT_PRU_INSTALLDIR
) -C
$(@D
)/examples
31 define PRU_SOFTWARE_SUPPORT_INSTALL_TARGET_CMDS
32 mkdir
-p
$(TARGET_DIR
)/usr
/share
/pru-software-support
33 cp
-dpfr
$(@D
)/examples
/* $(TARGET_DIR
)/usr
/share
/pru-software-support
/
36 $(eval
$(generic-package
))
37 $(eval
$(host-generic-package
))