package/logrotate: update upstream site in Config.in help
[buildroot-gz.git] / package / ti-cgt-pru / ti-cgt-pru.mk
blobd6de05e5dabc6f82242c26d5c3634b00f708742a
1 ################################################################################
3 # ti-cgt-pru
5 ################################################################################
7 TI_CGT_PRU_VERSION = 2.1.4
8 TI_CGT_PRU_SOURCE = ti_cgt_pru_$(TI_CGT_PRU_VERSION)_linux_installer_x86.bin
9 TI_CGT_PRU_SITE = http://downloads.ti.com/codegen/esd/cgt_public_sw/PRU/$(TI_CGT_PRU_VERSION)
10 TI_CGT_PRU_LICENSE = TI Technology and Software Publicly Available License (compiler + PRU library), \
11 Boost Software License 1.0 (compiler), \
12 BSD-2c, BSD-3c, MIT, Academic Free License 3.0, Hewlett-Packard (PRU library)
13 TI_CGT_PRU_LICENSE_FILES = PRU_Code_Generation_Tools_2.1.x_manifest.html \
14 PRU_CodeGen_Library_2.1_0222433C-30C1-442d-B5C6-2073BD97F80F.spdx.tag
16 define HOST_TI_CGT_PRU_EXTRACT_CMDS
17 chmod +x $(DL_DIR)/$(TI_CGT_PRU_SOURCE)
18 $(DL_DIR)/$(TI_CGT_PRU_SOURCE) --prefix $(@D) --mode unattended
19 mv $(@D)/ti-cgt-pru_$(TI_CGT_PRU_VERSION)/* $(@D)
20 rmdir $(@D)/ti-cgt-pru_$(TI_CGT_PRU_VERSION)/
21 endef
23 # Since this is largely prebuilt toolchain and likes to live in its
24 # own directory, put it in $(HOST_DIR)/usr/share/ti-cgt-pru/.
25 # Packages wanting to use this toolchain need to use this path as TI's
26 # standard PRU_CGT path e.g. make PRU_CGT=$(TI_CGT_PRU_INSTALLDIR)...
27 TI_CGT_PRU_INSTALLDIR = $(HOST_DIR)/usr/share/ti-cgt-pru
29 define HOST_TI_CGT_PRU_INSTALL_CMDS
30 mkdir -p $(TI_CGT_PRU_INSTALLDIR)
31 cp -dpfr $(@D)/* $(TI_CGT_PRU_INSTALLDIR)
32 endef
34 $(eval $(host-generic-package))