1 ################################################################################
5 ################################################################################
7 LIBARCHIVE_VERSION
= 3.1.2
8 LIBARCHIVE_SITE
= http
://www.libarchive.org
/downloads
9 LIBARCHIVE_INSTALL_STAGING
= YES
10 LIBARCHIVE_LICENSE
= BSD-2c
, BSD-3c
11 LIBARCHIVE_LICENSE_FILES
= COPYING
13 ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDTAR
),y
)
14 ifeq ($(BR2_STATIC_LIBS
),y
)
15 LIBARCHIVE_CONF_OPTS
+= --enable-bsdtar
=static
17 LIBARCHIVE_CONF_OPTS
+= --enable-bsdtar
=shared
20 LIBARCHIVE_CONF_OPTS
+= --disable-bsdtar
23 ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDCPIO
),y
)
24 ifeq ($(BR2_STATIC_LIBS
),y
)
25 LIBARCHIVE_CONF_OPTS
+= --enable-bsdcpio
=static
27 LIBARCHIVE_CONF_OPTS
+= --enable-bsdcpio
=shared
30 LIBARCHIVE_CONF_OPTS
+= --disable-bsdcpio
33 ifeq ($(BR2_PACKAGE_ACL
),y
)
34 LIBARCHIVE_DEPENDENCIES
+= acl
36 LIBARCHIVE_CONF_OPTS
+= --disable-acl
39 ifeq ($(BR2_PACKAGE_ATTR
),y
)
40 LIBARCHIVE_DEPENDENCIES
+= attr
42 LIBARCHIVE_CONF_OPTS
+= --disable-xattr
45 ifeq ($(BR2_PACKAGE_EXPAT
),y
)
46 LIBARCHIVE_DEPENDENCIES
+= expat
48 LIBARCHIVE_CONF_OPTS
+= --without-expat
51 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
52 LIBARCHIVE_DEPENDENCIES
+= libiconv
54 LIBARCHIVE_CONF_OPTS
+= --without-libiconv-prefix
57 ifeq ($(BR2_PACKAGE_LIBXML2
),y
)
58 LIBARCHIVE_DEPENDENCIES
+= libxml2
59 LIBARCHIVE_CONF_ENV
+= XML2_CONFIG
=$(STAGING_DIR
)/usr
/bin
/xml2-config
61 LIBARCHIVE_CONF_OPTS
+= --without-xml2
64 ifeq ($(BR2_PACKAGE_LZO
),y
)
65 LIBARCHIVE_DEPENDENCIES
+= lzo
67 LIBARCHIVE_CONF_OPTS
+= --without-lzo2
70 ifeq ($(BR2_PACKAGE_NETTLE
),y
)
71 LIBARCHIVE_DEPENDENCIES
+= nettle
73 LIBARCHIVE_CONF_OPTS
+= --without-nettle
76 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
77 LIBARCHIVE_DEPENDENCIES
+= openssl
79 LIBARCHIVE_CONF_OPTS
+= --without-openssl
82 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
83 LIBARCHIVE_DEPENDENCIES
+= zlib
85 LIBARCHIVE_CONF_OPTS
+= --without-zlib
88 ifeq ($(BR2_PACKAGE_XZ
),y
)
89 LIBARCHIVE_DEPENDENCIES
+= xz
90 LIBARCHIVE_CONF_OPTS
+= --with-lzma
92 LIBARCHIVE_CONF_OPTS
+= --without-lzma
95 $(eval
$(autotools-package
))