micropython: Bump version to v1.5
[buildroot-gz.git] / package / libarchive / libarchive.mk
blob206de3f58d77d08d909525021794934daca1ef02
1 ################################################################################
3 # libarchive
5 ################################################################################
7 LIBARCHIVE_VERSION = 3.1.2
8 LIBARCHIVE_SITE = http://www.libarchive.org/downloads
9 LIBARCHIVE_INSTALL_STAGING = YES
10 LIBARCHIVE_LICENSE = BSD-2c, BSD-3c
11 LIBARCHIVE_LICENSE_FILES = COPYING
13 ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDTAR),y)
14 ifeq ($(BR2_STATIC_LIBS),y)
15 LIBARCHIVE_CONF_OPTS += --enable-bsdtar=static
16 else
17 LIBARCHIVE_CONF_OPTS += --enable-bsdtar=shared
18 endif
19 else
20 LIBARCHIVE_CONF_OPTS += --disable-bsdtar
21 endif
23 ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDCPIO),y)
24 ifeq ($(BR2_STATIC_LIBS),y)
25 LIBARCHIVE_CONF_OPTS += --enable-bsdcpio=static
26 else
27 LIBARCHIVE_CONF_OPTS += --enable-bsdcpio=shared
28 endif
29 else
30 LIBARCHIVE_CONF_OPTS += --disable-bsdcpio
31 endif
33 ifeq ($(BR2_PACKAGE_ACL),y)
34 LIBARCHIVE_DEPENDENCIES += acl
35 else
36 LIBARCHIVE_CONF_OPTS += --disable-acl
37 endif
39 ifeq ($(BR2_PACKAGE_ATTR),y)
40 LIBARCHIVE_DEPENDENCIES += attr
41 else
42 LIBARCHIVE_CONF_OPTS += --disable-xattr
43 endif
45 ifeq ($(BR2_PACKAGE_EXPAT),y)
46 LIBARCHIVE_DEPENDENCIES += expat
47 else
48 LIBARCHIVE_CONF_OPTS += --without-expat
49 endif
51 ifeq ($(BR2_PACKAGE_LIBICONV),y)
52 LIBARCHIVE_DEPENDENCIES += libiconv
53 else
54 LIBARCHIVE_CONF_OPTS += --without-libiconv-prefix
55 endif
57 ifeq ($(BR2_PACKAGE_LIBXML2),y)
58 LIBARCHIVE_DEPENDENCIES += libxml2
59 LIBARCHIVE_CONF_ENV += XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
60 else
61 LIBARCHIVE_CONF_OPTS += --without-xml2
62 endif
64 ifeq ($(BR2_PACKAGE_LZO),y)
65 LIBARCHIVE_DEPENDENCIES += lzo
66 else
67 LIBARCHIVE_CONF_OPTS += --without-lzo2
68 endif
70 ifeq ($(BR2_PACKAGE_NETTLE),y)
71 LIBARCHIVE_DEPENDENCIES += nettle
72 else
73 LIBARCHIVE_CONF_OPTS += --without-nettle
74 endif
76 ifeq ($(BR2_PACKAGE_OPENSSL),y)
77 LIBARCHIVE_DEPENDENCIES += openssl
78 else
79 LIBARCHIVE_CONF_OPTS += --without-openssl
80 endif
82 ifeq ($(BR2_PACKAGE_ZLIB),y)
83 LIBARCHIVE_DEPENDENCIES += zlib
84 else
85 LIBARCHIVE_CONF_OPTS += --without-zlib
86 endif
88 ifeq ($(BR2_PACKAGE_XZ),y)
89 LIBARCHIVE_DEPENDENCIES += xz
90 LIBARCHIVE_CONF_OPTS += --with-lzma
91 else
92 LIBARCHIVE_CONF_OPTS += --without-lzma
93 endif
95 $(eval $(autotools-package))