1 ################################################################################
5 ################################################################################
6 LESSTIF_VERSION
= 0.95.2
7 LESSTIF_SOURCE
= lesstif-
$(LESSTIF_VERSION
).
tar.bz2
8 LESSTIF_SITE
= http
://downloads.sourceforge.net
/project
/lesstif
/lesstif
/$(LESSTIF_VERSION
)
9 LESSTIF_INSTALL_STAGING
= YES
10 LESSTIF_DEPENDENCIES
= \
14 LESSTIF_LICENSE
= LGPLv2
+
15 LESSTIF_LICENSE_FILES
= COPYING.LIB
18 --with-freetype-config
=$(STAGING_DIR
)/usr
/bin
/freetype-config \
19 --enable-production
=yes \
20 --enable-build-tests
=no \
23 # Reduces the buggy makefile to the smallest possible (and working) thing
24 define LESSTIF_NOMAN2HTML
25 echo
"all:" > $(@D
)/doc
/Makefile
26 echo
"" >> $(@D
)/doc
/Makefile
27 echo
"install:" >> $(@D
)/doc
/Makefile
28 echo
"" >> $(@D
)/doc
/Makefile
29 echo
"clean:" >> $(@D
)/doc
/Makefile
32 # Prevents to copy ac_find_motif.m4 on target, it would else
33 # be created at $(TARGET_DIR)/$(TOPDIR)/output/host/usr/share/aclocal/ac_find_motif.m4
34 define LESSTIF_FIXACLOCAL
35 sed
-i
-e
"/install-data-am: install-aclocalDATA/d" $(@D
)/scripts
/autoconf
/Makefile
38 LESSTIF_POST_CONFIGURE_HOOKS
+= LESSTIF_NOMAN2HTML
39 LESSTIF_POST_CONFIGURE_HOOKS
+= LESSTIF_FIXACLOCAL
41 $(eval
$(autotools-package
))