1 ################################################################################
5 ################################################################################
8 FFTW_SITE
= http
://www.fftw.org
9 FFTW_INSTALL_STAGING
= YES
11 FFTW_LICENSE_FILES
= COPYING
13 FFTW_CONF_OPTS
= --disable-fortran
15 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_PRECISION_SINGLE
),--enable
,--disable
)-single
16 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE
),--enable
,--disable
)-long-double
17 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_PRECISION_QUAD
),--enable
,--disable
)-quad-precision
19 FFTW_CFLAGS
= $(TARGET_CFLAGS
)
20 ifeq ($(BR2_PACKAGE_FFTW_FAST
),y
)
21 FFTW_CFLAGS
+= -O3
-ffast-math
25 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_USE_SSE
),--enable
,--disable
)-sse
26 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_USE_SSE2
),--enable
,--disable
)-sse2
29 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_USE_NEON
),--enable
,--disable
)-neon
30 FFTW_CFLAGS
+= $(if
$(BR2_PACKAGE_FFTW_USE_NEON
),-mfpu
=neon
)
32 # Generic optimisations
33 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS
),y
)
34 FFTW_CONF_OPTS
+= --enable-threads
--with-combined-threads
36 FFTW_CONF_OPTS
+= --disable-threads
38 FFTW_CONF_OPTS
+= $(if
$(BR2_GCC_ENABLE_OPENMP
),--enable
,--disable
)-openmp
40 FFTW_CONF_OPTS
+= CFLAGS
="$(FFTW_CFLAGS)"
42 $(eval
$(autotools-package
))