snowball-{hdmiservice, init}: remove packages
[buildroot-gz.git] / package / libxml2 / libxml2.mk
blob2a7153ad17f4651bd3cf1b842d95b653693e80e2
1 ################################################################################
3 # libxml2
5 ################################################################################
7 LIBXML2_VERSION = 2.9.4
8 LIBXML2_SITE = ftp://xmlsoft.org/libxml2
9 LIBXML2_INSTALL_STAGING = YES
10 LIBXML2_LICENSE = MIT
11 LIBXML2_LICENSE_FILES = COPYING
12 LIBXML2_CONFIG_SCRIPTS = xml2-config
14 # relocation truncated to fit: R_68K_GOT16O
15 ifeq ($(BR2_m68k_cf),y)
16 LIBXML2_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mxgot"
17 endif
19 LIBXML2_CONF_OPTS = --with-gnu-ld --without-python --without-debug
21 HOST_LIBXML2_DEPENDENCIES = host-pkgconf
22 LIBXML2_DEPENDENCIES = host-pkgconf
24 HOST_LIBXML2_CONF_OPTS = --without-zlib --without-lzma --without-python
26 ifeq ($(BR2_PACKAGE_ZLIB),y)
27 LIBXML2_DEPENDENCIES += zlib
28 LIBXML2_CONF_OPTS += --with-zlib=$(STAGING_DIR)/usr
29 else
30 LIBXML2_CONF_OPTS += --without-zlib
31 endif
33 ifeq ($(BR2_PACKAGE_XZ),y)
34 LIBXML2_DEPENDENCIES += xz
35 LIBXML2_CONF_OPTS += --with-lzma
36 else
37 LIBXML2_CONF_OPTS += --without-lzma
38 endif
40 LIBXML2_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
42 ifeq ($(BR2_ENABLE_LOCALE)$(BR2_PACKAGE_LIBICONV),y)
43 LIBXML2_CONF_OPTS += --with-iconv
44 else
45 LIBXML2_CONF_OPTS += --without-iconv
46 endif
48 $(eval $(autotools-package))
49 $(eval $(host-autotools-package))
51 # libxml2 for the host
52 LIBXML2_HOST_BINARY = $(HOST_DIR)/usr/bin/xmllint