1 ################################################################################
5 ################################################################################
7 ALLJOYN_TCL_BASE_REV
= 16.04
8 ALLJOYN_TCL_BASE_VERSION
= $(ALLJOYN_TCL_BASE_REV
).00
9 ALLJOYN_TCL_BASE_SOURCE
= alljoyn-base_tcl-
$(ALLJOYN_TCL_BASE_VERSION
).
tar.gz
10 ALLJOYN_TCL_BASE_SITE
= \
11 https
://mirrors.kernel.org
/allseenalliance
/alljoyn
/$(ALLJOYN_TCL_BASE_REV
)
12 # See https://allseenalliance.org/alliance/ip-policy
13 ALLJOYN_TCL_BASE_LICENSE
= ISC
15 ALLJOYN_TCL_BASE_DEPENDENCIES
= host-scons alljoyn-tcl
16 ALLJOYN_TCL_BASE_INSTALL_STAGING
= YES
18 # AllJoyn Base Thin Core can be compiled in debug or release mode. By default,
19 # AllJoyn Base Thin Core is built in debug mode.
20 ALLJOYN_TCL_BASE_VARIANT
= release
22 ALLJOYN_TCL_BASE_SCONS_OPTS
= \
25 VARIANT
=$(ALLJOYN_TCL_BASE_VARIANT
) \
28 AJTCL_DIST
=$(STAGING_DIR
) \
31 define ALLJOYN_TCL_BASE_BUILD_CMDS
32 cd
$(@D
); $(SCONS
) $(ALLJOYN_TCL_BASE_SCONS_OPTS
)
35 define ALLJOYN_TCL_BASE_INSTALL_STAGING_CMDS
36 cp
-a
$(@D
)/dist/lib
/lib
* $(STAGING_DIR
)/usr
/lib
/
37 cp
-a
$(@D
)/dist/include/* $(STAGING_DIR
)/usr
/include/
40 # Only install AllJoyn Base Thin Core dynamic libraries into target directory
41 define ALLJOYN_TCL_BASE_INSTALL_TARGET_CMDS
42 cp
-a
$(@D
)/dist/lib
/lib
*.so
* $(TARGET_DIR
)/usr
/lib
/
45 $(eval
$(generic-package
))