1 ################################################################################
5 ################################################################################
8 GAWK_SOURCE
= gawk-
$(GAWK_VERSION
).
tar.xz
9 GAWK_SITE
= $(BR2_GNU_MIRROR
)/gawk
10 GAWK_DEPENDENCIES
= host-gawk
12 GAWK_LICENSE_FILES
= COPYING
14 # Prefer full-blown gawk over busybox awk
15 ifeq ($(BR2_PACKAGE_BUSYBOX
),y
)
16 GAWK_DEPENDENCIES
+= busybox
19 ifeq ($(BR2_PACKAGE_LIBSIGSEGV
),y
)
20 GAWK_DEPENDENCIES
+= libsigsegv
23 # --with-mpfr requires an argument so just let
24 # configure find it automatically
25 ifeq ($(BR2_PACKAGE_MPFR
),y
)
26 GAWK_DEPENDENCIES
+= mpfr
28 GAWK_CONF_OPTS
+= --without-mpfr
31 # --with-readline requires an argument so just let
32 # configure find it automatically
33 ifeq ($(BR2_PACKAGE_READLINE
),y
)
34 GAWK_DEPENDENCIES
+= readline
36 GAWK_CONF_OPTS
+= --without-readline
39 HOST_GAWK_CONF_OPTS
= --without-readline
--without-mpfr
41 define GAWK_CREATE_SYMLINK
42 ln
-sf
/usr
/bin
/gawk
$(TARGET_DIR
)/usr
/bin
/awk
45 GAWK_POST_INSTALL_TARGET_HOOKS
+= GAWK_CREATE_SYMLINK
47 # Assume we support shared libs
48 # The check isn't cross-compile friendly and it's mandatory anyway
49 define GAWK_DISABLE_SHARED_CHECK
50 $(SED
) 's/ check-for-shared-lib-support//' $(@D
)/extension
/Makefile.in
53 GAWK_POST_PATCH_HOOKS
+= GAWK_DISABLE_SHARED_CHECK
55 $(eval
$(autotools-package
))
56 $(eval
$(host-autotools-package
))