libgtk3: remove non-existent configure options
[buildroot-gz.git] / package / hplip / hplip.mk
blobcd1be042a530f0ffd77c1de220341a553c4687df
1 ################################################################################
3 # hplip
5 ################################################################################
7 HPLIP_VERSION = 3.16.11
8 HPLIP_SITE = http://downloads.sourceforge.net/hplip/hplip
9 HPLIP_AUTORECONF = YES
10 HPLIP_DEPENDENCIES = cups libusb jpeg host-pkgconf
11 HPLIP_LICENSE = GPLv2, BSD-3c, MIT
12 HPLIP_LICENSE_FILES = COPYING
14 HPLIP_CONF_OPTS = \
15 --disable-qt4 \
16 --disable-scan-build \
17 --disable-gui-build \
18 --disable-doc-build \
19 --disable-network-build \
20 --enable-hpcups-install \
21 --disable-hpijs-install \
22 --enable-cups-ppd-install \
23 --enable-cups-drv-install \
24 --disable-foomatic-ppd-install \
25 --disable-foomatic-drv-install \
26 --disable-foomatic-rip-hplip-install \
27 --enable-new-hpcups \
28 --enable-lite-build
30 # build system does not support cups-config
31 HPLIP_CONF_ENV = LIBS=`$(STAGING_DIR)/usr/bin/cups-config --libs`
33 ifeq ($(BR2_PACKAGE_DBUS),y)
34 HPLIP_CONF_OPTS += --enable-dbus-build
35 HPLIP_DEPENDENCIES += dbus
36 else
37 HPLIP_CONF_OPTS += --disable-dbus-build
38 endif
40 define HPLIP_POST_INSTALL_TARGET_FIXUP
41 mkdir -p $(TARGET_DIR)/usr/share/hplip/data/models
42 cp $(@D)/data/models/* $(TARGET_DIR)/usr/share/hplip/data/models
43 endef
44 HPLIP_POST_INSTALL_TARGET_HOOKS += HPLIP_POST_INSTALL_TARGET_FIXUP
46 $(eval $(autotools-package))