1 ################################################################################
5 ################################################################################
8 RNG_TOOLS_SITE
= http
://downloads.sourceforge.net
/project
/gkernel
/rng-tools
/$(RNG_TOOLS_VERSION
)
9 RNG_TOOLS_LICENSE
= GPLv2
10 RNG_TOOLS_LICENSE_FILES
= COPYING
12 # Work around for uClibc or musl toolchains which lack argp_*()
14 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE
),y
)
15 RNG_TOOLS_CONF_ENV
+= LIBS
="-largp"
16 RNG_TOOLS_DEPENDENCIES
+= argp-standalone
19 ifeq ($(BR2_PACKAGE_LIBGCRYPT
),y
)
20 RNG_TOOLS_DEPENDENCIES
+= libgcrypt
22 RNG_TOOLS_CONF_OPTS
+= --without-libgcrypt
25 define RNG_TOOLS_INSTALL_INIT_SYSV
26 $(INSTALL
) -D
-m
755 package
/rng-tools
/S21rngd \
27 $(TARGET_DIR
)/etc
/init.d
/S21rngd
30 define RNG_TOOLS_INSTALL_INIT_SYSTEMD
31 $(INSTALL
) -D
-m
644 package
/rng-tools
/rngd.service \
32 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/rngd.service
33 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
34 ln
-fs ..
/..
/..
/..
/usr
/lib
/systemd
/system
/rngd.service \
35 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/rngd.service
38 $(eval
$(autotools-package
))