1 ################################################################################
5 ################################################################################
7 INPUT_EVENT_DAEMON_VERSION
= v0.1
.3
8 INPUT_EVENT_DAEMON_SITE
= $(call github
,gandro
,input-event-daemon
,$(INPUT_EVENT_DAEMON_VERSION
))
9 INPUT_EVENT_DAEMON_LICENSE
= input-event-daemon license
10 INPUT_EVENT_DAEMON_LICENSE_FILES
= README
12 define INPUT_EVENT_DAEMON_BUILD_CMDS
13 touch
$(@D
)/input-event-table.h
14 $(MAKE
) CC
="$(TARGET_CC)" CFLAGS
="$(TARGET_CFLAGS)" \
15 LDFLAGS
="$(TARGET_LDFLAGS)" -C
$(@D
)
18 define INPUT_EVENT_DAEMON_INSTALL_TARGET_CMDS
19 $(INSTALL
) -m
755 -D
$(@D
)/input-event-daemon \
20 $(TARGET_DIR
)/usr
/bin
/input-event-daemon
21 $(INSTALL
) -m
644 -D
$(@D
)/docs
/sample.conf \
22 $(TARGET_DIR
)/etc
/input-event-daemon.conf
25 define INPUT_EVENT_DAEMON_INSTALL_INIT_SYSV
26 $(INSTALL
) -m
0755 -D package
/input-event-daemon
/S99input-event-daemon \
27 $(TARGET_DIR
)/etc
/init.d
/S99input-event-daemon
30 define INPUT_EVENT_DAEMON_INSTALL_INIT_SYSTEMD
31 $(INSTALL
) -D
-m
644 package
/input-event-daemon
/input-event-daemon.service \
32 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/input-event-daemon.service
33 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
34 ln
-sf
/usr
/lib
/systemd
/system
/input-event-daemon.service \
35 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/input-event-daemon.service
38 $(eval
$(generic-package
))