1 ################################################################################
5 ################################################################################
8 READLINE_SITE
= $(BR2_GNU_MIRROR
)/readline
9 READLINE_INSTALL_STAGING
= YES
10 READLINE_DEPENDENCIES
= ncurses
11 HOST_READLINE_DEPENDENCIES
= host-ncurses
12 READLINE_CONF_ENV
= bash_cv_func_sigsetjmp
=yes \
13 bash_cv_wcwidth_broken
=no
14 READLINE_LICENSE
= GPLv3
+
15 READLINE_LICENSE_FILES
= COPYING
17 define READLINE_PURGE_EXAMPLES
18 rm -rf
$(TARGET_DIR
)/usr
/share
/readline
20 READLINE_POST_INSTALL_TARGET_HOOKS
+= READLINE_PURGE_EXAMPLES
22 define READLINE_INSTALL_INPUTRC
23 $(INSTALL
) -D
-m
644 package
/readline
/inputrc
$(TARGET_DIR
)/etc
/inputrc
25 READLINE_POST_INSTALL_TARGET_HOOKS
+= READLINE_INSTALL_INPUTRC
27 ifneq ($(BR2_STATIC_LIBS
),y
)
28 # libraries get installed read only, so strip fails
29 define READLINE_INSTALL_FIXUPS_SHARED
30 chmod
+w
$(addprefix $(TARGET_DIR
)/usr
/lib
/,libhistory.so.
* libreadline.so.
*)
32 READLINE_POST_INSTALL_TARGET_HOOKS
+= READLINE_INSTALL_FIXUPS_SHARED
35 $(eval
$(autotools-package
))
36 $(eval
$(host-autotools-package
))