package/nodejs: security bump for 0.10.x to version 0.10.42
[buildroot-gz.git] / package / readline / readline.mk
blob763197085e15be5f3a950178db4b6d42b2684b3e
1 ################################################################################
3 # readline
5 ################################################################################
7 READLINE_VERSION = 6.3
8 READLINE_SITE = $(BR2_GNU_MIRROR)/readline
9 READLINE_INSTALL_STAGING = YES
10 READLINE_DEPENDENCIES = ncurses
11 HOST_READLINE_DEPENDENCIES = host-ncurses
12 READLINE_CONF_ENV = bash_cv_func_sigsetjmp=yes \
13 bash_cv_wcwidth_broken=no
14 READLINE_LICENSE = GPLv3+
15 READLINE_LICENSE_FILES = COPYING
17 define READLINE_PURGE_EXAMPLES
18 rm -rf $(TARGET_DIR)/usr/share/readline
19 endef
20 READLINE_POST_INSTALL_TARGET_HOOKS += READLINE_PURGE_EXAMPLES
22 define READLINE_INSTALL_INPUTRC
23 $(INSTALL) -D -m 644 package/readline/inputrc $(TARGET_DIR)/etc/inputrc
24 endef
25 READLINE_POST_INSTALL_TARGET_HOOKS += READLINE_INSTALL_INPUTRC
27 ifneq ($(BR2_STATIC_LIBS),y)
28 # libraries get installed read only, so strip fails
29 define READLINE_INSTALL_FIXUPS_SHARED
30 chmod +w $(addprefix $(TARGET_DIR)/usr/lib/,libhistory.so.* libreadline.so.*)
31 endef
32 READLINE_POST_INSTALL_TARGET_HOOKS += READLINE_INSTALL_FIXUPS_SHARED
33 endif
35 $(eval $(autotools-package))
36 $(eval $(host-autotools-package))