gcc: preserve CXXFLAGS_FOR_TARGET
[buildroot-gz.git] / package / powertop / powertop.mk
blob53be483a6d33217c99041cce84d7479409298b81
1 ################################################################################
3 # powertop
5 ################################################################################
7 POWERTOP_VERSION = 2.7
8 POWERTOP_SITE = https://01.org/sites/default/files/downloads/powertop
9 POWERTOP_DEPENDENCIES = pciutils ncurses libnl host-gettext host-pkgconf
10 POWERTOP_LICENSE = GPLv2
11 POWERTOP_LICENSE_FILES = COPYING
12 # We're patching Makefile.am
13 POWERTOP_AUTORECONF = YES
14 POWERTOP_GETTEXTIZE = YES
16 ifeq ($(BR2_NEEDS_GETTEXT),y)
17 POWERTOP_DEPENDENCIES += gettext
18 POWERTOP_CONF_ENV += LIBS='-lintl'
19 endif
21 # Help powertop at finding the right ncurses library depending on
22 # which one is available.
23 ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
24 POWERTOP_CONF_ENV += ac_cv_search_delwin="-lncursesw"
25 else
26 POWERTOP_CONF_ENV += ac_cv_search_delwin="-lncurses"
27 endif
29 $(eval $(autotools-package))