logrotate: fix build with gcc 6
[buildroot-gz.git] / package / fluxbox / fluxbox.mk
blob305dd9abae9635addbc1988c86d3438aaed18064
1 ################################################################################
3 # fluxbox
5 ################################################################################
7 FLUXBOX_VERSION = 1.3.7
8 FLUXBOX_SOURCE = fluxbox-$(FLUXBOX_VERSION).tar.xz
9 FLUXBOX_SITE = http://downloads.sourceforge.net/project/fluxbox/fluxbox/$(FLUXBOX_VERSION)
10 FLUXBOX_LICENSE = MIT
11 FLUXBOX_LICENSE_FILES = COPYING
13 FLUXBOX_CONF_OPTS = \
14 --x-includes=$(STAGING_DIR)/usr/include/X11 \
15 --x-libraries=$(STAGING_DIR)/usr/lib
16 FLUXBOX_DEPENDENCIES = xlib_libX11 $(if $(BR2_PACKAGE_LIBICONV),libiconv)
18 ifeq ($(BR2_PACKAGE_FREETYPE),y)
19 FLUXBOX_CONF_OPTS += --enable-freetype2
20 FLUXBOX_DEPENDENCIES += freetype
21 else
22 FLUXBOX_CONF_OPTS += --disable-freetype2
23 endif
25 ifeq ($(BR2_PACKAGE_IMLIB2_X),y)
26 FLUXBOX_CONF_OPTS += --enable-imlib2
27 FLUXBOX_DEPENDENCIES += imlib2
28 else
29 FLUXBOX_CONF_OPTS += --disable-imlib2
30 endif
32 ifeq ($(BR2_PACKAGE_LIBFRIBIDI),y)
33 FLUXBOX_CONF_OPTS += --enable-fribidi
34 FLUXBOX_DEPENDENCIES += libfribidi
35 else
36 FLUXBOX_CONF_OPTS += --disable-fribidi
37 endif
39 ifeq ($(BR2_PACKAGE_XLIB_LIBXFT),y)
40 FLUXBOX_CONF_OPTS += --enable-xft
41 FLUXBOX_DEPENDENCIES += xlib_libXft
42 else
43 FLUXBOX_CONF_OPTS += --disable-xft
44 endif
46 ifeq ($(BR2_PACKAGE_XLIB_LIBXRENDER),y)
47 FLUXBOX_CONF_OPTS += --enable-xrender
48 FLUXBOX_DEPENDENCIES += xlib_libXrender
49 else
50 FLUXBOX_CONF_OPTS += --disable-xrender
51 endif
53 ifeq ($(BR2_PACKAGE_XLIB_LIBXPM),y)
54 FLUXBOX_CONF_OPTS += --enable-xpm
55 FLUXBOX_DEPENDENCIES += xlib_libXpm
56 else
57 FLUXBOX_CONF_OPTS += --disable-xpm
58 endif
60 ifeq ($(BR2_PACKAGE_XLIB_LIBXINERAMA),y)
61 FLUXBOX_CONF_OPTS += --enable-xinerama
62 FLUXBOX_DEPENDENCIES += xlib_libXinerama
63 else
64 FLUXBOX_CONF_OPTS += --disable-xinerama
65 endif
67 ifeq ($(BR2_PACKAGE_XLIB_LIBXEXT),y)
68 FLUXBOX_CONF_OPTS += --enable-xext
69 FLUXBOX_DEPENDENCIES += xlib_libXext
70 else
71 FLUXBOX_CONF_OPTS += --disable-xext
72 endif
74 ifeq ($(BR2_PACKAGE_XLIB_LIBXRANDR),y)
75 FLUXBOX_CONF_OPTS += --enable-xrandr
76 FLUXBOX_DEPENDENCIES += xlib_libXrandr
77 else
78 FLUXBOX_CONF_OPTS += --disable-xrandr
79 endif
81 define FLUXBOX_INSTALL_XSESSION_FILE
82 $(INSTALL) -m 0755 -D package/fluxbox/xsession \
83 $(TARGET_DIR)/root/.xsession
84 endef
86 FLUXBOX_POST_INSTALL_TARGET_HOOKS += FLUXBOX_INSTALL_XSESSION_FILE
88 $(eval $(autotools-package))