logrotate: fix build with gcc 6
[buildroot-gz.git] / package / gupnp-tools / gupnp-tools.mk
blob75920db09ace699eadaa5b8d378d6db2d3330f3a
1 ################################################################################
3 # gupnp-tools
5 ################################################################################
7 GUPNP_TOOLS_VERSION_MAJOR = 0.8
8 GUPNP_TOOLS_VERSION = $(GUPNP_TOOLS_VERSION_MAJOR).12
9 GUPNP_TOOLS_SOURCE = gupnp-tools-$(GUPNP_TOOLS_VERSION).tar.xz
10 GUPNP_TOOLS_SITE = \
11 http://ftp.gnome.org/pub/gnome/sources/gupnp-tools/$(GUPNP_TOOLS_VERSION_MAJOR)
12 GUPNP_TOOLS_LICENSE = GPLv2+
13 GUPNP_TOOLS_LICENSE_FILES = COPYING
14 GUPNP_TOOLS_INSTALL_STAGING = YES
15 GUPNP_TOOLS_DEPENDENCIES = \
16 host-pkgconf \
17 libglib2 \
18 libxml2 \
19 gssdp \
20 gupnp \
21 libsoup \
22 libgtk3
24 ifeq ($(BR2_PACKAGE_GUPNP_AV),y)
25 GUPNP_TOOLS_CONF_OPTS += --with-av
26 GUPNP_TOOLS_DEPENDENCIES += gupnp-av
27 else
28 GUPNP_TOOLS_CONF_OPTS += --without-av
29 endif
31 ifeq ($(BR2_PACKAGE_GTKSOURCEVIEW),y)
32 GUPNP_TOOLS_DEPENDENCIES += gtksourceview
33 endif
35 $(eval $(autotools-package))