logrotate: fix build with gcc 6
[buildroot-gz.git] / package / openmpi / openmpi.mk
blobc5b8a01b6f18c3bbaa4c18c610c3b51b25beecfa
1 ################################################################################
3 # openmpi
5 ################################################################################
7 OPENMPI_VERSION_MAJOR = 1.10
8 OPENMPI_VERSION = $(OPENMPI_VERSION_MAJOR).2
9 OPENMPI_SITE = https://www.open-mpi.org/software/ompi/v$(OPENMPI_VERSION_MAJOR)/downloads
10 OPENMPI_SOURCE = openmpi-$(OPENMPI_VERSION).tar.bz2
11 OPENMPI_LICENSE = BSD-3c
12 OPENMPI_LICENSE_FILES = LICENSE
13 OPENMPI_INSTALL_STAGING = YES
14 OPENMPI_CONF_OPTS = --disable-vt
16 # Enabling Fortran support requires pre-seeding the configure script
17 # with various values that cannot be guessed, so we provide cache
18 # files for various architectures.
20 ifeq ($(BR2_TOOLCHAIN_HAS_FORTRAN),y)
21 ifeq ($(BR2_mips)$(BR2_mipsel),y)
22 OPENMPI_FORTRAN_CONF_CACHE = package/openmpi/openmpi-mips32-fortran.cache
23 else ifeq ($(BR2_mips64)$(BR2_mips64el),y)
24 OPENMPI_FORTRAN_CONF_CACHE = package/openmpi/openmpi-mips64-fortran.cache
25 endif
26 endif
28 ifneq ($(OPENMPI_FORTRAN_CONF_CACHE),)
29 define OPENMPI_COPY_FORTRAN_CACHE
30 cp $(OPENMPI_FORTRAN_CONF_CACHE) $(@D)/openmpi-config.cache
31 endef
33 OPENMPI_POST_PATCH_HOOKS += OPENMPI_COPY_FORTRAN_CACHE
34 OPENMPI_CONF_OPTS += \
35 --enable-mpi-fortran=yes \
36 --cache-file=$(@D)/openmpi-config.cache
37 else
38 OPENMPI_CONF_OPTS += --enable-mpi-fortran=no
39 endif
41 $(eval $(autotools-package))