perl-path-tiny: bump to version 0.061
[buildroot-gz.git] / package / apr / apr.mk
blobcbae0ff73bfbe0b710b60b311e5b90de60c2483e
1 ################################################################################
3 # apr
5 ################################################################################
7 APR_VERSION = 1.5.1
8 APR_SITE = http://archive.apache.org/dist/apr
9 APR_LICENSE = Apache-2.0
10 APR_LICENSE_FILES = LICENSE
11 APR_INSTALL_STAGING = YES
12 # We have a patch touching configure.in and Makefile.in,
13 # so we need to autoreconf:
14 APR_AUTORECONF = YES
15 APR_CONF_ENV = \
16 CC_FOR_BUILD="$(HOSTCC)" \
17 CFLAGS_FOR_BUILD="$(HOST_CFLAGS)" \
18 ac_cv_file__dev_zero=yes \
19 ac_cv_func_setpgrp_void=yes \
20 apr_cv_process_shared_works=yes \
21 apr_cv_mutex_robust_shared=no \
22 apr_cv_tcp_nodelay_with_cork=yes \
23 ac_cv_sizeof_struct_iovec=8 \
24 ac_cv_struct_rlimit=yes \
25 ac_cv_o_nonblock_inherited=no \
26 apr_cv_mutex_recursive=yes
27 APR_CONFIG_SCRIPTS = apr-1-config
29 # Doesn't even try to guess when cross compiling
30 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
31 APR_CONF_ENV += apr_cv_pthreads_lib="-lpthread"
32 endif
34 # Fix lfs detection when cross compiling
35 ifeq ($(BR2_LARGEFILE),y)
36 APR_CONF_ENV += apr_cv_use_lfs64=yes
37 endif
39 define APR_CLEANUP_UNNEEDED_FILES
40 $(RM) -rf $(TARGET_DIR)/usr/build-1/
41 endef
43 APR_POST_INSTALL_TARGET_HOOKS += APR_CLEANUP_UNNEEDED_FILES
45 define APR_FIXUP_RULES_MK
46 $(SED) 's%apr_builddir=%apr_builddir=$(STAGING_DIR)%' \
47 $(STAGING_DIR)/usr/build-1/apr_rules.mk
48 $(SED) 's%apr_builders=%apr_builders=$(STAGING_DIR)%' \
49 $(STAGING_DIR)/usr/build-1/apr_rules.mk
50 $(SED) 's%top_builddir=%top_builddir=$(STAGING_DIR)%' \
51 $(STAGING_DIR)/usr/build-1/apr_rules.mk
52 endef
54 APR_POST_INSTALL_STAGING_HOOKS += APR_FIXUP_RULES_MK
56 $(eval $(autotools-package))