perl-path-tiny: bump to version 0.061
[buildroot-gz.git] / package / fbv / fbv.mk
blobfe24a6f1ff6e7366dbabda30a972c4b8b895861b
1 ################################################################################
3 # fbv
5 ################################################################################
7 FBV_VERSION = 1.0b
8 FBV_SITE = http://s-tech.elsat.net.pl/fbv
10 FBV_LICENSE = GPLv2
11 FBV_LICENSE_FILES = COPYING
13 ### image format dependencies and configure options
14 FBV_DEPENDENCIES = # empty
15 FBV_CONFIGURE_OPTS = # empty
16 ifeq ($(BR2_PACKAGE_FBV_PNG),y)
17 FBV_DEPENDENCIES += libpng
19 # libpng in turn depends on other libraries
20 ifeq ($(BR2_STATIC_LIBS),y)
21 FBV_CONFIGURE_OPTS += "--libs=$(shell $(PKG_CONFIG_HOST_BINARY) --libs libpng --static)"
22 endif
24 else
25 FBV_CONFIGURE_OPTS += --without-libpng
26 endif
27 ifeq ($(BR2_PACKAGE_FBV_JPEG),y)
28 FBV_DEPENDENCIES += jpeg
29 else
30 FBV_CONFIGURE_OPTS += --without-libjpeg
31 endif
32 ifeq ($(BR2_PACKAGE_FBV_GIF),y)
33 FBV_DEPENDENCIES += libungif
34 else
35 FBV_CONFIGURE_OPTS += --without-libungif
36 endif
38 #fbv doesn't support cross-compilation
39 define FBV_CONFIGURE_CMDS
40 (cd $(FBV_DIR); rm -f config.cache; \
41 $(TARGET_CONFIGURE_OPTS) \
42 $(TARGET_CONFIGURE_ARGS) \
43 ./configure \
44 --prefix=/usr \
45 $(FBV_CONFIGURE_OPTS) \
47 endef
49 define FBV_BUILD_CMDS
50 $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
51 endef
53 define FBV_INSTALL_TARGET_CMDS
54 $(INSTALL) -D $(@D)/fbv $(TARGET_DIR)/usr/bin/fbv
55 endef
57 $(eval $(autotools-package))