1 ################################################################################
5 ################################################################################
8 FBV_SITE
= http
://s-tech.elsat.net.pl
/fbv
11 FBV_LICENSE_FILES
= COPYING
13 ### image format dependencies and configure options
14 FBV_DEPENDENCIES
= # empty
15 FBV_CONFIGURE_OPTS
= # empty
16 ifeq ($(BR2_PACKAGE_FBV_PNG
),y
)
17 FBV_DEPENDENCIES
+= libpng
19 # libpng in turn depends on other libraries
20 ifeq ($(BR2_STATIC_LIBS
),y
)
21 FBV_CONFIGURE_OPTS
+= "--libs=$(shell $(PKG_CONFIG_HOST_BINARY) --libs libpng --static)"
25 FBV_CONFIGURE_OPTS
+= --without-libpng
27 ifeq ($(BR2_PACKAGE_FBV_JPEG
),y
)
28 FBV_DEPENDENCIES
+= jpeg
30 FBV_CONFIGURE_OPTS
+= --without-libjpeg
32 ifeq ($(BR2_PACKAGE_FBV_GIF
),y
)
33 FBV_DEPENDENCIES
+= libungif
35 FBV_CONFIGURE_OPTS
+= --without-libungif
38 #fbv doesn't support cross-compilation
39 define FBV_CONFIGURE_CMDS
40 (cd
$(FBV_DIR
); rm -f config.cache
; \
41 $(TARGET_CONFIGURE_OPTS
) \
42 $(TARGET_CONFIGURE_ARGS
) \
45 $(FBV_CONFIGURE_OPTS
) \
50 $(MAKE
) $(TARGET_CONFIGURE_OPTS
) -C
$(@D
)
53 define FBV_INSTALL_TARGET_CMDS
54 $(INSTALL
) -D
$(@D
)/fbv
$(TARGET_DIR
)/usr
/bin
/fbv
57 $(eval
$(autotools-package
))