1 ################################################################################
5 ################################################################################
8 AUDIT_SITE
= http
://people.redhat.com
/sgrubb
/audit
9 AUDIT_LICENSE
= GPLv2
+ (programs
), unclear
(libraries
)
10 AUDIT_LICENSE_FILES
= COPYING
12 AUDIT_INSTALL_STAGING
= YES
14 AUDIT_CONF_OPTS
= --without-python
--without-python3
--disable-zos-remote
16 ifeq ($(BR2_PACKAGE_LIBCAP_NG
),y
)
17 AUDIT_DEPENDENCIES
+= libcap-ng
18 AUDIT_CONF_OPTS
+= --with-libcap-ng
=yes
20 AUDIT_CONF_OPTS
+= --with-libcap-ng
=no
23 # For i386, x86-64 and PowerPC, the system call tables are
24 # unconditionally included. However, for ARM(eb) and AArch64, then
25 # need to be explicitly enabled.
27 ifeq ($(BR2_arm
)$(BR2_armeb
),y
)
28 AUDIT_CONF_OPTS
+= --with-arm
30 ifeq ($(BR2_aarch64
),y
)
31 AUDIT_CONF_OPTS
+= --with-aarch64
34 ifeq ($(BR2_INIT_SYSTEMD
),y
)
35 AUDIT_CONF_OPTS
+= --enable-systemd
37 AUDIT_CONF_OPTS
+= --disable-systemd
40 define AUDIT_INSTALL_INIT_SYSV
41 $(INSTALL
) -D
-m
755 package
/audit
/S01auditd
$(TARGET_DIR
)/etc
/init.d
/S01auditd
44 define AUDIT_INSTALL_INIT_SYSTEMD
45 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
46 ln
-fs ..
/..
/..
/..
/usr
/lib
/systemd
/system
/auditd.service \
47 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/auditd.service
49 $(INSTALL
) -D
-m
644 package
/audit
/audit_tmpfiles.conf \
50 $(TARGET_DIR
)/usr
/lib
/tmpfiles.d
/audit.conf
53 define AUDIT_INSTALL_CLEANUP
54 $(RM
) -rf
$(TARGET_DIR
)/etc
/rc.d
55 $(RM
) -rf
$(TARGET_DIR
)/etc
/sysconfig
57 AUDIT_POST_INSTALL_TARGET_HOOKS
+= AUDIT_INSTALL_CLEANUP
59 HOST_AUDIT_CONF_OPTS
= \
62 --disable-zos-remote \
65 $(eval
$(autotools-package
))
66 $(eval
$(host-autotools-package
))