audit: bump version to 2.7
[buildroot-gz.git] / package / audit / audit.mk
bloba5766624e34d84b76425034f9e30f4da8cc9bac0
1 ################################################################################
3 # audit
5 ################################################################################
7 AUDIT_VERSION = 2.7
8 AUDIT_SITE = http://people.redhat.com/sgrubb/audit
9 AUDIT_LICENSE = GPLv2+ (programs), unclear (libraries)
10 AUDIT_LICENSE_FILES = COPYING
12 AUDIT_INSTALL_STAGING = YES
14 AUDIT_CONF_OPTS = --without-python --without-python3 --disable-zos-remote
16 ifeq ($(BR2_PACKAGE_LIBCAP_NG),y)
17 AUDIT_DEPENDENCIES += libcap-ng
18 AUDIT_CONF_OPTS += --with-libcap-ng=yes
19 else
20 AUDIT_CONF_OPTS += --with-libcap-ng=no
21 endif
23 # For i386, x86-64 and PowerPC, the system call tables are
24 # unconditionally included. However, for ARM(eb) and AArch64, then
25 # need to be explicitly enabled.
27 ifeq ($(BR2_arm)$(BR2_armeb),y)
28 AUDIT_CONF_OPTS += --with-arm
29 endif
30 ifeq ($(BR2_aarch64),y)
31 AUDIT_CONF_OPTS += --with-aarch64
32 endif
34 ifeq ($(BR2_INIT_SYSTEMD),y)
35 AUDIT_CONF_OPTS += --enable-systemd
36 else
37 AUDIT_CONF_OPTS += --disable-systemd
38 endif
40 define AUDIT_INSTALL_INIT_SYSV
41 $(INSTALL) -D -m 755 package/audit/S01auditd $(TARGET_DIR)/etc/init.d/S01auditd
42 endef
44 define AUDIT_INSTALL_INIT_SYSTEMD
45 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
46 ln -fs ../../../../usr/lib/systemd/system/auditd.service \
47 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/auditd.service
49 $(INSTALL) -D -m 644 package/audit/audit_tmpfiles.conf \
50 $(TARGET_DIR)/usr/lib/tmpfiles.d/audit.conf
51 endef
53 define AUDIT_INSTALL_CLEANUP
54 $(RM) -rf $(TARGET_DIR)/etc/rc.d
55 $(RM) -rf $(TARGET_DIR)/etc/sysconfig
56 endef
57 AUDIT_POST_INSTALL_TARGET_HOOKS += AUDIT_INSTALL_CLEANUP
59 HOST_AUDIT_CONF_OPTS = \
60 --without-python \
61 --without-python3 \
62 --disable-zos-remote \
63 --without-libcap-ng
65 $(eval $(autotools-package))
66 $(eval $(host-autotools-package))