- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
[cdrkit.git] / cdrkit.spec
blob99c6f6252ea2a013ca112b44b391a3a2ae669dd9
1 Summary: A collection of CD/DVD utilities
2 Name: cdrkit
3 Version: 1.1.11
4 Release: 15%{?dist}
5 License: GPLv2
6 Group: Applications/System
7 URL: http://cdrkit.org/
8 Source: http://cdrkit.org/releases/cdrkit-%{version}.tar.gz
10 Patch1: cdrkit-1.1.8-werror.patch
11 Patch2: cdrkit-1.1.9-efi-boot.patch
12 Patch4: cdrkit-1.1.9-no_mp3.patch
13 Patch5: cdrkit-1.1.9-buffer_overflow.patch
14 Patch6: cdrkit-1.1.10-build-fix.patch
15 Patch7: cdrkit-1.1.11-manpagefix.patch
16 Patch8: cdrkit-1.1.11-rootstat.patch
17 Patch9: cdrkit-1.1.11-usalinst.patch
18 Patch10: cdrkit-1.1.11-readsegfault.patch
19 Patch11: cdrkit-1.1.11-format.patch
20 Patch12: cdrkit-1.1.11-handler.patch
21 Patch13: cdrkit-1.1.11-dvdman.patch
22 Patch14: cdrkit-1.1.11-paranoiacdda.patch
23 Patch15: cdrkit-1.1.11-utf8.patch
24 Patch16: cdrkit-1.1.11-cmakewarn.patch
26 BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
28 %description
29 cdrkit is a collection of CD/DVD utilities.
31 %package -n wodim
32 Summary: A command line CD/DVD recording program
33 Group: Applications/Archiving
34 Obsoletes: dvdrecord <= 0:0.1.5
35 Provides: dvdrecord = 0:0.1.5.1
36 Obsoletes: cdrecord < 9:2.01-12
37 Provides: cdrecord = 9:2.01-12
38 Requires: libusal = %{version}-%{release}
39 Requires(preun): %{_sbindir}/alternatives coreutils
40 Requires(post): %{_sbindir}/alternatives coreutils
42 %description -n wodim
43 Wodim is an application for creating audio and data CDs. Wodim
44 works with many different brands of CD recorders, fully supports
45 multi-sessions and provides human-readable error messages.
47 %package -n genisoimage
48 Summary: Creates an image of an ISO9660 file-system
49 Group: Applications/System
50 Obsoletes: mkisofs < 9:2.01-12
51 Provides: mkisofs = 9:2.01-12
52 Requires: libusal = %{version}-%{release}
53 Requires(preun): %{_sbindir}/alternatives coreutils
54 Requires(post): %{_sbindir}/alternatives coreutils
56 %description -n genisoimage
57 The genisoimage program is used as a pre-mastering program; i.e., it
58 generates the ISO9660 file-system. Genisoimage takes a snapshot of
59 a given directory tree and generates a binary image of the tree
60 which will correspond to an ISO9660 file-system when written to
61 a block device. Genisoimage is used for writing CD-ROMs, and includes
62 support for creating boot-able El Torito CD-ROMs.
64 Install the genisoimage package if you need a program for writing
65 CD-ROMs.
67 %package -n dirsplit
68 Summary: Utility to split directories
69 Group: Applications/System
70 Requires: perl >= 4:5.8.1
71 Requires: genisoimage = %{version}-%{release}
73 %description -n dirsplit
74 This utility is used to split directories into chunks before burning.
75 Chunk size is usually set to fit to a CD/DVD.
77 %package -n icedax
78 Group: Applications/Multimedia
79 Summary: A utility for sampling/copying .wav files from digital audio CDs
80 Obsoletes: cdda2wav < 9:2.01-12
81 Provides: cdda2wav = 9:2.01-12
82 Requires: libusal = %{version}-%{release}
83 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
84 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
85 Requires: vorbis-tools
86 Requires: cdparanoia
87 BuildRequires: cdparanoia-devel
89 %description -n icedax
90 Icedax is a sampling utility for CD-ROM drives that are capable of
91 providing a CD's audio data in digital form to your host. Audio data
92 read from the CD can be saved as .wav or .sun format sound files.
93 Recording formats include stereo/mono, 8/12/16 bits and different
94 rates. Icedax can also be used as a CD player.
96 %package -n libusal
97 Summary: Library to communicate with SCSI devices
98 Group: Development/Libraries
100 %description -n libusal
101 The libusal package contains C libraries that allows applications
102 to communicate with SCSI devices and is well suitable for writing
103 CD-R media.
105 %package -n libusal-devel
106 Summary: Development files for libusal
107 Group: Development/Libraries
108 Requires: libusal = %{version}-%{release}
110 %description -n libusal-devel
111 The libusal-devel package contains C libraries and header files
112 for developing applications that use libusal for communication with
113 SCSI devices.
115 %prep
116 %setup -q
117 %patch1 -p1 -b .werror
118 %patch2 -p1 -b .efi
119 %patch4 -p1 -b .no_mp3
120 %patch5 -p1 -b .buffer_overflow
121 %patch6 -p1 -b .build-fix
122 %patch7 -p1 -b .manpagefix
123 %patch8 -p1 -b .rootstat
124 %patch9 -p1 -b .usalinst
125 %patch10 -p1 -b .readsegfault
126 %patch11 -p1 -b .format
127 %patch12 -p1 -b .handler
128 %patch13 -p1 -b .dvdman
129 %patch14 -p1 -b .paranoiacdda
130 # not using -b since otherwise backup files would be included into rpm
131 %patch15 -p1
132 %patch16 -p1 -b .cmakewarn
134 # we do not want bundled paranoia library
135 rm -rf libparanoia
137 find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
138 find doc -type f -print0 | xargs -0 chmod a-x
141 %build
142 mkdir fedora
143 cd fedora
144 export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -Wno-unused-but-set-variable -Wno-array-bounds -fno-strict-aliasing"
145 export CXXFLAGS="$CFLAGS"
146 export FFLAGS="$CFLAGS"
147 %cmake CMAKE_VERBOSE=1 \
148 -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
149 -DBUILD_SHARED_LIBS:BOOL=ON \
152 make VERBOSE=1 %{?_smp_mflags}
154 %install
155 cd fedora
156 make install DESTDIR=$RPM_BUILD_ROOT
157 perl -pi -e 's#^require v5.8.1;##g' $RPM_BUILD_ROOT%{_bindir}/dirsplit
158 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkisofs
159 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkhybrid
160 ln -s icedax $RPM_BUILD_ROOT%{_bindir}/cdda2wav
161 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/cdrecord
162 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/dvdrecord
164 # missing man page. Do symlink like in debian
165 ln -sf wodim.1.gz $RPM_BUILD_ROOT/%{_mandir}/man1/netscsid.1.gz
167 # we don't need cdda2mp3 since we don't have any mp3 {en,de}coder
168 rm $RPM_BUILD_ROOT%{_bindir}/cdda2mp3
170 %post -n wodim
171 link=`readlink %{_bindir}/cdrecord`
172 if [ "$link" == "%{_bindir}/wodim" ]; then
173 rm -f %{_bindir}/cdrecord
175 link=`readlink %{_bindir}/dvdrecord`
176 if [ "$link" == "wodim" ]; then
177 rm -f %{_bindir}/dvdrecord
180 %{_sbindir}/alternatives --install %{_bindir}/cdrecord cdrecord \
181 %{_bindir}/wodim 50 \
182 --slave %{_mandir}/man1/cdrecord.1.gz cdrecord-cdrecordman \
183 %{_mandir}/man1/wodim.1.gz \
184 --slave %{_bindir}/dvdrecord cdrecord-dvdrecord %{_bindir}/wodim \
185 --slave %{_mandir}/man1/dvdrecord.1.gz cdrecord-dvdrecordman \
186 %{_mandir}/man1/wodim.1.gz \
187 --slave %{_bindir}/readcd cdrecord-readcd %{_bindir}/readom \
188 --slave %{_mandir}/man1/readcd.1.gz cdrecord-readcdman \
189 %{_mandir}/man1/readom.1.gz
191 %preun -n wodim
192 if [ $1 = 0 ]; then
193 %{_sbindir}/alternatives --remove cdrecord %{_bindir}/wodim
196 %post -n genisoimage
197 link=`readlink %{_bindir}/mkisofs`
198 if [ "$link" == "genisoimage" ]; then
199 rm -f %{_bindir}/mkisofs
202 %{_sbindir}/alternatives --install %{_bindir}/mkisofs mkisofs \
203 %{_bindir}/genisoimage 50 \
204 --slave %{_mandir}/man1/mkisofs.1.gz mkisofs-mkisofsman \
205 %{_mandir}/man1/genisoimage.1.gz \
206 --slave %{_bindir}/mkhybrid mkisofs-mkhybrid %{_bindir}/genisoimage \
207 --slave %{_mandir}/man1/mkhybrid.1.gz mkisofs-mkhybridman \
208 %{_mandir}/man1/genisoimage.1.gz
210 %preun -n genisoimage
211 if [ $1 = 0 ]; then
212 %{_sbindir}/alternatives --remove mkisofs %{_bindir}/genisoimage
215 %post -n icedax
216 link=`readlink %{_bindir}/cdda2wav`
217 if [ "$link" == "icedax" ]; then
218 rm -f %{_bindir}/cdda2wav
220 %{_sbindir}/alternatives --install %{_bindir}/cdda2wav cdda2wav \
221 %{_bindir}/icedax 50 \
222 --slave %{_mandir}/man1/cdda2wav.1.gz cdda2wav-cdda2wavman \
223 %{_mandir}/man1/icedax.1.gz
225 %preun -n icedax
226 if [ $1 = 0 ]; then
227 %{_sbindir}/alternatives --remove cdda2wav %{_bindir}/icedax
230 %post -n libusal -p /sbin/ldconfig
232 %postun -n libusal -p /sbin/ldconfig
234 %files -n wodim
235 %doc Changelog COPYING FAQ FORK START
236 %doc doc/READMEs doc/wodim
237 %{_bindir}/devdump
238 %{_bindir}/wodim
239 %ghost %{_bindir}/cdrecord
240 %ghost %{_bindir}/dvdrecord
241 %{_bindir}/readom
242 %{_sbindir}/netscsid
243 %{_mandir}/man1/devdump.*
244 %{_mandir}/man1/wodim.*
245 %{_mandir}/man1/netscsid.*
246 %{_mandir}/man1/readom.*
248 %files -n icedax
249 %doc doc/icedax COPYING
250 %{_bindir}/icedax
251 %ghost %{_bindir}/cdda2wav
252 %{_bindir}/cdda2ogg
253 %{_mandir}/man1/icedax.*
254 %{_mandir}/man1/cdda2ogg.*
255 %{_mandir}/man1/list_audio_tracks.*
257 %files -n genisoimage
258 %doc doc/genisoimage COPYING
259 %{_bindir}/genisoimage
260 %ghost %{_bindir}/mkisofs
261 %ghost %{_bindir}/mkhybrid
262 %{_bindir}/isodebug
263 %{_bindir}/isodump
264 %{_bindir}/isoinfo
265 %{_bindir}/isovfy
266 %{_bindir}/pitchplay
267 %{_bindir}/readmult
268 %{_mandir}/man5/genisoimagerc.*
269 %{_mandir}/man1/genisoimage.*
270 %{_mandir}/man1/isodebug.*
271 %{_mandir}/man1/isodump.*
272 %{_mandir}/man1/isoinfo.*
273 %{_mandir}/man1/isovfy.*
274 %{_mandir}/man1/pitchplay.*
275 %{_mandir}/man1/readmult.*
277 %files -n dirsplit
278 %{_bindir}/dirsplit
279 %{_mandir}/man1/dirsplit.*
281 %files -n libusal
282 %doc doc/plattforms/README.linux Changelog COPYING FAQ FORK START
283 %{_libdir}/libusal.so.*
284 %{_libdir}/librols.so.*
286 %files -n libusal-devel
287 %doc COPYING
288 %{_libdir}/libusal.so
289 %{_libdir}/librols.so
290 %{_includedir}/usal
292 %changelog
293 * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-15
294 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
296 * Wed Oct 03 2012 Honza Horak <hhorak@redhat.com> - 1.1.11-14
297 - Add coreutils as preun/post requirements for wodim and genisoimage
298 Resolves: #862554
300 * Mon Aug 27 2012 Honza Horak <hhorak@redhat.com> - 1.1.11-13
301 - Add mkhybrid(1) as a symlink to genisoimage(1)
302 - Spec file cleanup
304 * Mon Jul 30 2012 Honza Horak <hhorak@redhat.com> - 1.1.11-12
305 - Use system cdparanoia instead of old bundled version
306 - Build libusal as a shared library
307 - Messages from rpmlint clean-up
309 * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-11
310 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
312 * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-10
313 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
315 * Wed Dec 07 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-9
316 - Fix driver specification in man pages
317 (Resolves: #711623)
319 * Thu Jun 02 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-8
320 - Fix segmentation fault when icedax exits while sleeping after ctrl-c
321 (Resolves: #709902)
323 * Tue May 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-7
324 - Fix automatic formatting of DVD+RW if needed
325 (Resolves: #519465)
327 * Thu Mar 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-6
328 - Added Provides: libusal-static for libusal-devel subpackage
329 (Resolves: #688347)
331 * Mon Mar 07 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-5
332 - Fix segmentation fault in readom
333 (Resolves: #682591)
335 * Thu Feb 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-4
336 - Library libusal is installed in order to be used by other apps
337 (Resolves: #588508)
338 https://bugzilla.redhat.com/show_bug.cgi?id=588508
340 * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-3
341 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
343 * Mon Jan 31 2011 Honza Horak <hhorak@redhat.com> 1.1.11-2
344 - fixed man page missing arguments (Resolves: #647024)
345 https://bugzilla.redhat.com/show_bug.cgi?id=647024
346 - fixed erroneous "Unknown file type (unallocated)" warning
347 (Resolves: #174667)
348 https://bugzilla.redhat.com/show_bug.cgi?id=174667
350 * Mon Oct 18 2010 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.11-1
351 - new upstream version 1.1.11
353 * Mon Jun 21 2010 Roman Rakus <rrakus@redhat.com> - 1.1.10-2
354 - Added missing manpage for netscsid (symlink to wodim manpage)
356 * Wed Jan 20 2010 Nikola Pajkovsky <npajkovs@redhat.com> - 1.1.10-1
357 - new upstream version 1.1.10
359 * Tue Aug 11 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-10
360 - fix #508449. fix string overflow breakage when using the -root
362 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-9
363 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
365 * Thu Jul 16 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-8
366 - fix buffer overflow
368 * Fri Jul 10 2009 Adam Jackson <ajax@redhat.com> 1.1.9-7
369 - Move dirsplit to a subpackage to isolate the perl dependency.
371 * Tue Jun 15 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-6
372 - rename functions as they conflict with glibc
373 - Don't push cdda2mp3 because we don't have any mp3 coder
374 Resolves: #505918
376 * Tue Jun 02 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-5
377 - Added Requires vorbis-tools in icedax (rhbz #503699)
379 * Wed Feb 25 2009 Peter Jones <pjones@redhat.com> - 1.1.9-4
380 - Add support for EFI boot images.
382 * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
383 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
385 * Thu Feb 12 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-2
386 - Use -fno-strict-aliasing to prevent strict_aliasing warnings/errors
388 * Mon Oct 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.9-1
389 - Bump to version 1.1.9
391 * Tue May 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.8-1
392 - Version 1.1.8 - old patches included
393 - added bzip2-devel to build requirements
394 - fixed #171510 - preserve directory permissions
396 * Wed Feb 27 2008 Harald Hoyer <harald@redhat.com> 1.1.6-11
397 - refined -Werror patch
399 * Mon Feb 25 2008 Harald Hoyer <harald@redhat.com> 1.1.6-10
400 - patched to compile with -Werror (rhbz#429385)
402 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-9
403 - fixed loop on error message for old dev syntax (rhbz#429386)
405 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-8
406 - added file-devel to build requirements
408 * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.6-7
409 - Autorebuild for GCC 4.3
411 * Tue Sep 25 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-6
412 - fixed readcd man page symlink
414 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-5
415 - fixed rhbz#255001 - icedax --devices segfaults
416 - fixed rhbz#249357 - Typo in wodim output
418 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
419 - play stupid tricks, to let alternatives make the links and
420 rpm not removing them afterwards
421 - removed bogus warning for "." and ".."
423 * Thu Sep 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-3
424 - fixed rhbz#248262
425 - switched to alternatives
427 * Fri Aug 17 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-2
428 - changed license to GPLv2
430 * Wed Jun 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-1
431 - version 1.1.6
432 - added readcd symlink
434 * Mon Apr 23 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-4
435 - bump obsoletes/provides
437 * Tue Feb 27 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-3
438 - applied specfile changes as in bug #224365
440 * Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-1
441 - version 1.1.2