Added missing manpage for netscsid (symlink to wodim manpage)
[cdrkit/templates.git] / cdrkit.spec
blob4682fd7879927b796fe065cb9e7434f307d15073
1 Summary: A collection of CD/DVD utilities
2 Name: cdrkit
3 Version: 1.1.10
4 Release: 2%{?dist}
5 License: GPLv2
6 Group: Applications/System
7 URL: http://cdrkit.org/
8 Source: http://cdrkit.org/releases/cdrkit-%{version}.tar.gz
10 Patch1: cdrkit-1.1.8-werror.patch
11 Patch2: cdrkit-1.1.9-efi-boot.patch
12 Patch4: cdrkit-1.1.9-no_mp3.patch
13 Patch5: cdrkit-1.1.9-buffer_overflow.patch
14 #Patch6: cdrkit-1.1.9-rr_joliet.patch
15 Patch6: cdrkit-1.1.10-build-fix.patch
17 BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21 %description
22 cdrkit is a collection of CD/DVD utilities.
24 %package -n wodim
25 Summary: A command line CD/DVD recording program
26 Group: Applications/Archiving
27 Obsoletes: dvdrecord <= 0:0.1.5
28 Provides: dvdrecord = 0:0.1.5.1
29 Obsoletes: cdrecord < 9:2.01-12
30 Provides: cdrecord = 9:2.01-12
31 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
32 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
34 %description -n wodim
35 Wodim is an application for creating audio and data CDs. Wodim
36 works with many different brands of CD recorders, fully supports
37 multi-sessions and provides human-readable error messages.
39 %package -n genisoimage
40 Summary: Creates an image of an ISO9660 filesystem
41 Group: Applications/System
42 Obsoletes: mkisofs < 9:2.01-12
43 Provides: mkisofs = 9:2.01-12
44 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
45 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
47 %description -n genisoimage
48 The genisoimage program is used as a pre-mastering program; i.e., it
49 generates the ISO9660 filesystem. Genisoimage takes a snapshot of
50 a given directory tree and generates a binary image of the tree
51 which will correspond to an ISO9660 filesystem when written to
52 a block device. Genisoimage is used for writing CD-ROMs, and includes
53 support for creating bootable El Torito CD-ROMs.
55 Install the genisoimage package if you need a program for writing
56 CD-ROMs.
58 %package -n dirsplit
59 Summary: dirsplit utility
60 Group: Applications/System
61 Requires: perl >= 4:5.8.1
62 Requires: genisoimage = %{version}-%{release}
64 %description -n dirsplit
65 dirsplit
67 %package -n icedax
68 Group: Applications/Multimedia
69 Summary: A utility for sampling/copying .wav files from digital audio CDs
70 Obsoletes: cdda2wav < 9:2.01-12
71 Provides: cdda2wav = 9:2.01-12
72 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
73 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
74 Requires: vorbis-tools
76 %description -n icedax
77 Icedax is a sampling utility for CD-ROM drives that are capable of
78 providing a CD's audio data in digital form to your host. Audio data
79 read from the CD can be saved as .wav or .sun format sound files.
80 Recording formats include stereo/mono, 8/12/16 bits and different
81 rates. Icedax can also be used as a CD player.
83 %prep
84 %setup -q
85 %patch1 -p1 -b .werror
86 %patch2 -p1 -b .efi
87 %patch4 -p1 -b .no_mp3
88 %patch5 -p1 -b .buffer_overflow
89 #%patch6 -p1 -b .rr_joliet
90 %patch6 -p1 -b .build-fix
92 find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
93 find doc -type f -print0 | xargs -0 chmod a-x
96 %build
97 mkdir fedora
98 cd fedora
99 export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -fno-strict-aliasing"
100 export CXXFLAGS="$CFLAGS"
101 export FFLAGS="$CFLAGS"
102 cmake .. \
103 -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
104 -DBUILD_SHARED_LIBS:BOOL=ON
105 make VERBOSE=1 %{?_smp_mflags}
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 cd fedora
110 make install DESTDIR=$RPM_BUILD_ROOT
111 perl -pi -e 's#^require v5.8.1;##g' $RPM_BUILD_ROOT%{_bindir}/dirsplit
112 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkisofs
113 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkhybrid
114 ln -s icedax $RPM_BUILD_ROOT%{_bindir}/cdda2wav
115 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/cdrecord
116 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/dvdrecord
118 # missing man page. Do symlink like in debian
119 ln -sf wodim.1.gz $RPM_BUILD_ROOT/%{_mandir}/man1/netscsid.1.gz
121 # we don't need cdda2mp3 since we don't have any mp3 {en,de}coder
122 rm $RPM_BUILD_ROOT%{_bindir}/cdda2mp3
124 %clean
125 rm -rf $RPM_BUILD_ROOT
127 %post -n wodim
128 link=`readlink %{_bindir}/cdrecord`
129 if [ "$link" == "%{_bindir}/wodim" ]; then
130 rm -f %{_bindir}/cdrecord
132 link=`readlink %{_bindir}/dvdrecord`
133 if [ "$link" == "wodim" ]; then
134 rm -f %{_bindir}/dvdrecord
137 %{_sbindir}/alternatives --install %{_bindir}/cdrecord cdrecord \
138 %{_bindir}/wodim 50 \
139 --slave %{_mandir}/man1/cdrecord.1.gz cdrecord-cdrecordman \
140 %{_mandir}/man1/wodim.1.gz \
141 --slave %{_bindir}/dvdrecord cdrecord-dvdrecord %{_bindir}/wodim \
142 --slave %{_mandir}/man1/dvdrecord.1.gz cdrecord-dvdrecordman \
143 %{_mandir}/man1/wodim.1.gz \
144 --slave %{_bindir}/readcd cdrecord-readcd %{_bindir}/readom \
145 --slave %{_mandir}/man1/readcd.1.gz cdrecord-readcdman \
146 %{_mandir}/man1/readom.1.gz
148 %preun -n wodim
149 if [ $1 = 0 ]; then
150 %{_sbindir}/alternatives --remove cdrecord %{_bindir}/wodim
153 %post -n genisoimage
154 link=`readlink %{_bindir}/mkisofs`
155 if [ "$link" == "genisoimage" ]; then
156 rm -f %{_bindir}/mkisofs
159 %{_sbindir}/alternatives --install %{_bindir}/mkisofs mkisofs \
160 %{_bindir}/genisoimage 50 \
161 --slave %{_mandir}/man1/mkisofs.1.gz mkisofs-mkisofsman \
162 %{_mandir}/man1/genisoimage.1.gz \
163 --slave %{_bindir}/mkhybrid mkisofs-mkhybrid %{_bindir}/genisoimage
165 %preun -n genisoimage
166 if [ $1 = 0 ]; then
167 %{_sbindir}/alternatives --remove mkisofs %{_bindir}/genisoimage
170 %post -n icedax
171 link=`readlink %{_bindir}/cdda2wav`
172 if [ "$link" == "icedax" ]; then
173 rm -f %{_bindir}/cdda2wav
175 %{_sbindir}/alternatives --install %{_bindir}/cdda2wav cdda2wav \
176 %{_bindir}/icedax 50 \
177 --slave %{_mandir}/man1/cdda2wav.1.gz cdda2wav-cdda2wavman \
178 %{_mandir}/man1/icedax.1.gz
180 %preun -n icedax
181 if [ $1 = 0 ]; then
182 %{_sbindir}/alternatives --remove cdda2wav %{_bindir}/icedax
185 %files -n wodim
186 %defattr(-,root,root)
187 %doc Changelog COPYING FAQ FORK START
188 %doc doc/READMEs doc/wodim
189 %{_bindir}/devdump
190 %{_bindir}/wodim
191 %ghost %{_bindir}/cdrecord
192 %ghost %{_bindir}/dvdrecord
193 %{_bindir}/readom
194 %{_sbindir}/netscsid
195 %{_mandir}/man1/devdump.*
196 %{_mandir}/man1/wodim.*
197 %{_mandir}/man1/netscsid.*
198 %{_mandir}/man1/readom.*
200 %files -n icedax
201 %defattr(-,root,root)
202 %doc doc/icedax COPYING
203 %{_bindir}/icedax
204 %ghost %{_bindir}/cdda2wav
205 %{_bindir}/cdda2ogg
206 %{_mandir}/man1/icedax.*
207 %{_mandir}/man1/cdda2ogg.*
208 %{_mandir}/man1/list_audio_tracks.*
210 %files -n genisoimage
211 %defattr(-,root,root)
212 %doc doc/genisoimage COPYING
213 %{_bindir}/genisoimage
214 %ghost %{_bindir}/mkisofs
215 %ghost %{_bindir}/mkhybrid
216 %{_bindir}/isodebug
217 %{_bindir}/isodump
218 %{_bindir}/isoinfo
219 %{_bindir}/isovfy
220 %{_bindir}/pitchplay
221 %{_bindir}/readmult
222 %{_mandir}/man5/genisoimagerc.*
223 %{_mandir}/man1/genisoimage.*
224 %{_mandir}/man1/isodebug.*
225 %{_mandir}/man1/isodump.*
226 %{_mandir}/man1/isoinfo.*
227 %{_mandir}/man1/isovfy.*
228 %{_mandir}/man1/pitchplay.*
229 %{_mandir}/man1/readmult.*
231 %files -n dirsplit
232 %defattr(-,root,root)
233 %{_bindir}/dirsplit
234 %{_mandir}/man1/dirsplit.*
236 %changelog
237 * Mon Jun 21 2010 Roman Rakus <rrakus@redhat.com> - 1.1.10-2
238 - Added missing manpage for netscsid (symlink to wodim manpage)
240 * Wed Jan 20 2010 Nikola Pajkovsky <npajkovs@redhat.com> - 1.1.10-1
241 - new upstream version 1.1.10
243 * Tue Aug 11 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-10
244 - fix #508449. fix string overflow breakage when using the -root
246 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-9
247 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
249 * Thu Jul 16 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-8
250 - fix buffer overflow
252 * Fri Jul 10 2009 Adam Jackson <ajax@redhat.com> 1.1.9-7
253 - Move dirsplit to a subpackage to isolate the perl dependency.
255 * Tue Jun 15 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-6
256 - rename functions as they conflict with glibc
257 - Don't push cdda2mp3 because we don't have any mp3 coder
258 Resolves: #505918
260 * Tue Jun 02 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-5
261 - Added Requires vorbis-tools in icedax (rhbz #503699)
263 * Wed Feb 25 2009 Peter Jones <pjones@redhat.com> - 1.1.9-4
264 - Add support for EFI boot images.
266 * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
267 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
269 * Thu Feb 12 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-2
270 - Use -fno-strict-aliasing to prevent strict_aliasing warnings/errors
272 * Mon Oct 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.9-1
273 - Bump to version 1.1.9
275 * Tue May 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.8-1
276 - Version 1.1.8 - old patches included
277 - added bzip2-devel to build requirements
278 - fixed #171510 - preserve directory permissions
280 * Wed Feb 27 2008 Harald Hoyer <harald@redhat.com> 1.1.6-11
281 - refined -Werror patch
283 * Mon Feb 25 2008 Harald Hoyer <harald@redhat.com> 1.1.6-10
284 - patched to compile with -Werror (rhbz#429385)
286 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-9
287 - fixed loop on error message for old dev syntax (rhbz#429386)
289 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-8
290 - added file-devel to build requirements
292 * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.6-7
293 - Autorebuild for GCC 4.3
295 * Tue Sep 25 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-6
296 - fixed readcd man page symlink
298 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-5
299 - fixed rhbz#255001 - icedax --devices segfaults
300 - fixed rhbz#249357 - Typo in wodim output
302 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
303 - play stupid tricks, to let alternatives make the links and
304 rpm not removing them afterwards
305 - removed bogus warning for "." and ".."
307 * Thu Sep 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-3
308 - fixed rhbz#248262
309 - switched to alternatives
311 * Fri Aug 17 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-2
312 - changed license to GPLv2
314 * Wed Jun 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-1
315 - version 1.1.6
316 - added readcd symlink
318 * Mon Apr 23 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-4
319 - bump obsoletes/provides
321 * Tue Feb 27 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-3
322 - applied specfile changes as in bug #224365
324 * Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-1
325 - version 1.1.2