new upstream version 1.1.10
[cdrkit/templates.git] / cdrkit.spec
blob7e414fb0c315105e487b94ea6214ae7ff0c1d1e0
1 Summary: A collection of CD/DVD utilities
2 Name: cdrkit
3 Version: 1.1.10
4 Release: 1%{?dist}
5 License: GPLv2
6 Group: Applications/System
7 URL: http://cdrkit.org/
8 Source: http://cdrkit.org/releases/cdrkit-%{version}.tar.gz
10 Patch1: cdrkit-1.1.8-werror.patch
11 Patch2: cdrkit-1.1.9-efi-boot.patch
12 Patch4: cdrkit-1.1.9-no_mp3.patch
13 Patch5: cdrkit-1.1.9-buffer_overflow.patch
14 #Patch6: cdrkit-1.1.9-rr_joliet.patch
15 Patch6: cdrkit-1.1.10-build-fix.patch
17 BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21 %description
22 cdrkit is a collection of CD/DVD utilities.
24 %package -n wodim
25 Summary: A command line CD/DVD recording program
26 Group: Applications/Archiving
27 Obsoletes: dvdrecord <= 0:0.1.5
28 Provides: dvdrecord = 0:0.1.5.1
29 Obsoletes: cdrecord < 9:2.01-12
30 Provides: cdrecord = 9:2.01-12
31 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
32 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
34 %description -n wodim
35 Wodim is an application for creating audio and data CDs. Wodim
36 works with many different brands of CD recorders, fully supports
37 multi-sessions and provides human-readable error messages.
39 %package -n genisoimage
40 Summary: Creates an image of an ISO9660 filesystem
41 Group: Applications/System
42 Obsoletes: mkisofs < 9:2.01-12
43 Provides: mkisofs = 9:2.01-12
44 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
45 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
47 %description -n genisoimage
48 The genisoimage program is used as a pre-mastering program; i.e., it
49 generates the ISO9660 filesystem. Genisoimage takes a snapshot of
50 a given directory tree and generates a binary image of the tree
51 which will correspond to an ISO9660 filesystem when written to
52 a block device. Genisoimage is used for writing CD-ROMs, and includes
53 support for creating bootable El Torito CD-ROMs.
55 Install the genisoimage package if you need a program for writing
56 CD-ROMs.
58 %package -n dirsplit
59 Summary: dirsplit utility
60 Group: Applications/System
61 Requires: perl >= 4:5.8.1
62 Requires: genisoimage = %{version}-%{release}
64 %description -n dirsplit
65 dirsplit
67 %package -n icedax
68 Group: Applications/Multimedia
69 Summary: A utility for sampling/copying .wav files from digital audio CDs
70 Obsoletes: cdda2wav < 9:2.01-12
71 Provides: cdda2wav = 9:2.01-12
72 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
73 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
74 Requires: vorbis-tools
76 %description -n icedax
77 Icedax is a sampling utility for CD-ROM drives that are capable of
78 providing a CD's audio data in digital form to your host. Audio data
79 read from the CD can be saved as .wav or .sun format sound files.
80 Recording formats include stereo/mono, 8/12/16 bits and different
81 rates. Icedax can also be used as a CD player.
83 %prep
84 %setup -q
85 %patch1 -p1 -b .werror
86 %patch2 -p1 -b .efi
87 %patch4 -p1 -b .no_mp3
88 %patch5 -p1 -b .buffer_overflow
89 #%patch6 -p1 -b .rr_joliet
90 %patch6 -p1 -b .build-fix
92 find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
93 find doc -type f -print0 | xargs -0 chmod a-x
96 %build
97 mkdir fedora
98 cd fedora
99 export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -fno-strict-aliasing"
100 export CXXFLAGS="$CFLAGS"
101 export FFLAGS="$CFLAGS"
102 cmake .. \
103 -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
104 -DBUILD_SHARED_LIBS:BOOL=ON
105 make VERBOSE=1 %{?_smp_mflags}
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 cd fedora
110 make install DESTDIR=$RPM_BUILD_ROOT
111 perl -pi -e 's#^require v5.8.1;##g' $RPM_BUILD_ROOT%{_bindir}/dirsplit
112 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkisofs
113 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkhybrid
114 ln -s icedax $RPM_BUILD_ROOT%{_bindir}/cdda2wav
115 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/cdrecord
116 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/dvdrecord
118 # we don't need cdda2mp3 since we don't have any mp3 {en,de}coder
119 rm $RPM_BUILD_ROOT%{_bindir}/cdda2mp3
121 %clean
122 rm -rf $RPM_BUILD_ROOT
124 %post -n wodim
125 link=`readlink %{_bindir}/cdrecord`
126 if [ "$link" == "%{_bindir}/wodim" ]; then
127 rm -f %{_bindir}/cdrecord
129 link=`readlink %{_bindir}/dvdrecord`
130 if [ "$link" == "wodim" ]; then
131 rm -f %{_bindir}/dvdrecord
134 %{_sbindir}/alternatives --install %{_bindir}/cdrecord cdrecord \
135 %{_bindir}/wodim 50 \
136 --slave %{_mandir}/man1/cdrecord.1.gz cdrecord-cdrecordman \
137 %{_mandir}/man1/wodim.1.gz \
138 --slave %{_bindir}/dvdrecord cdrecord-dvdrecord %{_bindir}/wodim \
139 --slave %{_mandir}/man1/dvdrecord.1.gz cdrecord-dvdrecordman \
140 %{_mandir}/man1/wodim.1.gz \
141 --slave %{_bindir}/readcd cdrecord-readcd %{_bindir}/readom \
142 --slave %{_mandir}/man1/readcd.1.gz cdrecord-readcdman \
143 %{_mandir}/man1/readom.1.gz
145 %preun -n wodim
146 if [ $1 = 0 ]; then
147 %{_sbindir}/alternatives --remove cdrecord %{_bindir}/wodim
150 %post -n genisoimage
151 link=`readlink %{_bindir}/mkisofs`
152 if [ "$link" == "genisoimage" ]; then
153 rm -f %{_bindir}/mkisofs
156 %{_sbindir}/alternatives --install %{_bindir}/mkisofs mkisofs \
157 %{_bindir}/genisoimage 50 \
158 --slave %{_mandir}/man1/mkisofs.1.gz mkisofs-mkisofsman \
159 %{_mandir}/man1/genisoimage.1.gz \
160 --slave %{_bindir}/mkhybrid mkisofs-mkhybrid %{_bindir}/genisoimage
162 %preun -n genisoimage
163 if [ $1 = 0 ]; then
164 %{_sbindir}/alternatives --remove mkisofs %{_bindir}/genisoimage
167 %post -n icedax
168 link=`readlink %{_bindir}/cdda2wav`
169 if [ "$link" == "icedax" ]; then
170 rm -f %{_bindir}/cdda2wav
172 %{_sbindir}/alternatives --install %{_bindir}/cdda2wav cdda2wav \
173 %{_bindir}/icedax 50 \
174 --slave %{_mandir}/man1/cdda2wav.1.gz cdda2wav-cdda2wavman \
175 %{_mandir}/man1/icedax.1.gz
177 %preun -n icedax
178 if [ $1 = 0 ]; then
179 %{_sbindir}/alternatives --remove cdda2wav %{_bindir}/icedax
182 %files -n wodim
183 %defattr(-,root,root)
184 %doc Changelog COPYING FAQ FORK START
185 %doc doc/READMEs doc/wodim
186 %{_bindir}/devdump
187 %{_bindir}/wodim
188 %ghost %{_bindir}/cdrecord
189 %ghost %{_bindir}/dvdrecord
190 %{_bindir}/readom
191 %{_sbindir}/netscsid
192 %{_mandir}/man1/devdump.*
193 %{_mandir}/man1/wodim.*
194 %{_mandir}/man1/readom.*
196 %files -n icedax
197 %defattr(-,root,root)
198 %doc doc/icedax COPYING
199 %{_bindir}/icedax
200 %ghost %{_bindir}/cdda2wav
201 %{_bindir}/cdda2ogg
202 %{_mandir}/man1/icedax.*
203 %{_mandir}/man1/cdda2ogg.*
204 %{_mandir}/man1/list_audio_tracks.*
206 %files -n genisoimage
207 %defattr(-,root,root)
208 %doc doc/genisoimage COPYING
209 %{_bindir}/genisoimage
210 %ghost %{_bindir}/mkisofs
211 %ghost %{_bindir}/mkhybrid
212 %{_bindir}/isodebug
213 %{_bindir}/isodump
214 %{_bindir}/isoinfo
215 %{_bindir}/isovfy
216 %{_bindir}/pitchplay
217 %{_bindir}/readmult
218 %{_mandir}/man5/genisoimagerc.*
219 %{_mandir}/man1/genisoimage.*
220 %{_mandir}/man1/isodebug.*
221 %{_mandir}/man1/isodump.*
222 %{_mandir}/man1/isoinfo.*
223 %{_mandir}/man1/isovfy.*
224 %{_mandir}/man1/pitchplay.*
225 %{_mandir}/man1/readmult.*
227 %files -n dirsplit
228 %defattr(-,root,root)
229 %{_bindir}/dirsplit
230 %{_mandir}/man1/dirsplit.*
232 %changelog
233 * Wed Jan 20 2010 Nikola Pajkovsky <npajkovs@redhat.com> - 1.1.10-1
234 - new upstream version 1.1.10
236 * Tue Aug 11 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-10
237 - fix #508449. fix string overflow breakage when using the -root
239 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-9
240 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
242 * Thu Jul 16 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-8
243 - fix buffer overflow
245 * Fri Jul 10 2009 Adam Jackson <ajax@redhat.com> 1.1.9-7
246 - Move dirsplit to a subpackage to isolate the perl dependency.
248 * Tue Jun 15 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-6
249 - rename functions as they conflict with glibc
250 - Don't push cdda2mp3 because we don't have any mp3 coder
251 Resolves: #505918
253 * Tue Jun 02 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-5
254 - Added Requires vorbis-tools in icedax (rhbz #503699)
256 * Wed Feb 25 2009 Peter Jones <pjones@redhat.com> - 1.1.9-4
257 - Add support for EFI boot images.
259 * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
260 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
262 * Thu Feb 12 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-2
263 - Use -fno-strict-aliasing to prevent strict_aliasing warnings/errors
265 * Mon Oct 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.9-1
266 - Bump to version 1.1.9
268 * Tue May 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.8-1
269 - Version 1.1.8 - old patches included
270 - added bzip2-devel to build requirements
271 - fixed #171510 - preserve directory permissions
273 * Wed Feb 27 2008 Harald Hoyer <harald@redhat.com> 1.1.6-11
274 - refined -Werror patch
276 * Mon Feb 25 2008 Harald Hoyer <harald@redhat.com> 1.1.6-10
277 - patched to compile with -Werror (rhbz#429385)
279 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-9
280 - fixed loop on error message for old dev syntax (rhbz#429386)
282 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-8
283 - added file-devel to build requirements
285 * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.6-7
286 - Autorebuild for GCC 4.3
288 * Tue Sep 25 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-6
289 - fixed readcd man page symlink
291 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-5
292 - fixed rhbz#255001 - icedax --devices segfaults
293 - fixed rhbz#249357 - Typo in wodim output
295 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
296 - play stupid tricks, to let alternatives make the links and
297 rpm not removing them afterwards
298 - removed bogus warning for "." and ".."
300 * Thu Sep 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-3
301 - fixed rhbz#248262
302 - switched to alternatives
304 * Fri Aug 17 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-2
305 - changed license to GPLv2
307 * Wed Jun 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-1
308 - version 1.1.6
309 - added readcd symlink
311 * Mon Apr 23 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-4
312 - bump obsoletes/provides
314 * Tue Feb 27 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-3
315 - applied specfile changes as in bug #224365
317 * Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-1
318 - version 1.1.2