- Move dirsplit to a subpackage to isolate the perl dependency.
[cdrkit/templates.git] / cdrkit.spec
blobbfded5f5b82a6850aab5e97caa1909df0a5e7c9c
1 Summary: A collection of CD/DVD utilities
2 Name: cdrkit
3 Version: 1.1.9
4 Release: 7%{?dist}
5 License: GPLv2
6 Group: Applications/System
7 URL: http://cdrkit.org/
8 Source: http://cdrkit.org/releases/cdrkit-%{version}.tar.gz
10 Patch1: cdrkit-1.1.8-werror.patch
11 Patch2: cdrkit-1.1.9-efi-boot.patch
12 Patch3: cdrkit-1.1.9-types.patch
13 Patch4: cdrkit-1.1.9-no_mp3.patch
15 BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19 %description
20 cdrkit is a collection of CD/DVD utilities.
22 %package -n wodim
23 Summary: A command line CD/DVD recording program
24 Group: Applications/Archiving
25 Obsoletes: dvdrecord <= 0:0.1.5
26 Provides: dvdrecord = 0:0.1.5.1
27 Obsoletes: cdrecord < 9:2.01-12
28 Provides: cdrecord = 9:2.01-12
29 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
30 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
32 %description -n wodim
33 Wodim is an application for creating audio and data CDs. Wodim
34 works with many different brands of CD recorders, fully supports
35 multi-sessions and provides human-readable error messages.
37 %package -n genisoimage
38 Summary: Creates an image of an ISO9660 filesystem
39 Group: Applications/System
40 Obsoletes: mkisofs < 9:2.01-12
41 Provides: mkisofs = 9:2.01-12
42 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
43 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
45 %description -n genisoimage
46 The genisoimage program is used as a pre-mastering program; i.e., it
47 generates the ISO9660 filesystem. Genisoimage takes a snapshot of
48 a given directory tree and generates a binary image of the tree
49 which will correspond to an ISO9660 filesystem when written to
50 a block device. Genisoimage is used for writing CD-ROMs, and includes
51 support for creating bootable El Torito CD-ROMs.
53 Install the genisoimage package if you need a program for writing
54 CD-ROMs.
56 %package -n dirsplit
57 Summary: dirsplit utility
58 Group: Applications/System
59 Requires: perl >= 4:5.8.1
60 Requires: genisoimage = %{version}-%{release}
62 %description -n dirsplit
63 dirsplit
65 %package -n icedax
66 Group: Applications/Multimedia
67 Summary: A utility for sampling/copying .wav files from digital audio CDs
68 Obsoletes: cdda2wav < 9:2.01-12
69 Provides: cdda2wav = 9:2.01-12
70 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
71 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
72 Requires: vorbis-tools
74 %description -n icedax
75 Icedax is a sampling utility for CD-ROM drives that are capable of
76 providing a CD's audio data in digital form to your host. Audio data
77 read from the CD can be saved as .wav or .sun format sound files.
78 Recording formats include stereo/mono, 8/12/16 bits and different
79 rates. Icedax can also be used as a CD player.
81 %prep
82 %setup -q
83 %patch1 -p1 -b .werror
84 %patch2 -p1 -b .efi
85 %patch3 -p1 -b .types
86 %patch4 -p1 -b .no_mp3
88 find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
89 find doc -type f -print0 | xargs -0 chmod a-x
92 %build
93 mkdir fedora
94 cd fedora
95 export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -fno-strict-aliasing"
96 export CXXFLAGS="$CFLAGS"
97 export FFLAGS="$CFLAGS"
98 cmake .. \
99 -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
100 -DBUILD_SHARED_LIBS:BOOL=ON
101 make VERBOSE=1 %{?_smp_mflags}
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 cd fedora
106 make install DESTDIR=$RPM_BUILD_ROOT
107 perl -pi -e 's#^require v5.8.1;##g' $RPM_BUILD_ROOT%{_bindir}/dirsplit
108 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkisofs
109 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkhybrid
110 ln -s icedax $RPM_BUILD_ROOT%{_bindir}/cdda2wav
111 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/cdrecord
112 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/dvdrecord
114 # we don't need cdda2mp3 since we don't have any mp3 {en,de}coder
115 rm $RPM_BUILD_ROOT%{_bindir}/cdda2mp3
117 %clean
118 rm -rf $RPM_BUILD_ROOT
120 %post -n wodim
121 link=`readlink %{_bindir}/cdrecord`
122 if [ "$link" == "%{_bindir}/wodim" ]; then
123 rm -f %{_bindir}/cdrecord
125 link=`readlink %{_bindir}/dvdrecord`
126 if [ "$link" == "wodim" ]; then
127 rm -f %{_bindir}/dvdrecord
130 %{_sbindir}/alternatives --install %{_bindir}/cdrecord cdrecord \
131 %{_bindir}/wodim 50 \
132 --slave %{_mandir}/man1/cdrecord.1.gz cdrecord-cdrecordman \
133 %{_mandir}/man1/wodim.1.gz \
134 --slave %{_bindir}/dvdrecord cdrecord-dvdrecord %{_bindir}/wodim \
135 --slave %{_mandir}/man1/dvdrecord.1.gz cdrecord-dvdrecordman \
136 %{_mandir}/man1/wodim.1.gz \
137 --slave %{_bindir}/readcd cdrecord-readcd %{_bindir}/readom \
138 --slave %{_mandir}/man1/readcd.1.gz cdrecord-readcdman \
139 %{_mandir}/man1/readom.1.gz
141 %preun -n wodim
142 if [ $1 = 0 ]; then
143 %{_sbindir}/alternatives --remove cdrecord %{_bindir}/wodim
146 %post -n genisoimage
147 link=`readlink %{_bindir}/mkisofs`
148 if [ "$link" == "genisoimage" ]; then
149 rm -f %{_bindir}/mkisofs
152 %{_sbindir}/alternatives --install %{_bindir}/mkisofs mkisofs \
153 %{_bindir}/genisoimage 50 \
154 --slave %{_mandir}/man1/mkisofs.1.gz mkisofs-mkisofsman \
155 %{_mandir}/man1/genisoimage.1.gz \
156 --slave %{_bindir}/mkhybrid mkisofs-mkhybrid %{_bindir}/genisoimage
158 %preun -n genisoimage
159 if [ $1 = 0 ]; then
160 %{_sbindir}/alternatives --remove mkisofs %{_bindir}/genisoimage
163 %post -n icedax
164 link=`readlink %{_bindir}/cdda2wav`
165 if [ "$link" == "icedax" ]; then
166 rm -f %{_bindir}/cdda2wav
168 %{_sbindir}/alternatives --install %{_bindir}/cdda2wav cdda2wav \
169 %{_bindir}/icedax 50 \
170 --slave %{_mandir}/man1/cdda2wav.1.gz cdda2wav-cdda2wavman \
171 %{_mandir}/man1/icedax.1.gz
173 %preun -n icedax
174 if [ $1 = 0 ]; then
175 %{_sbindir}/alternatives --remove cdda2wav %{_bindir}/icedax
178 %files -n wodim
179 %defattr(-,root,root)
180 %doc Changelog COPYING FAQ FORK START
181 %doc doc/READMEs doc/wodim
182 %{_bindir}/devdump
183 %{_bindir}/wodim
184 %ghost %{_bindir}/cdrecord
185 %ghost %{_bindir}/dvdrecord
186 %{_bindir}/readom
187 %{_sbindir}/netscsid
188 %{_mandir}/man1/devdump.*
189 %{_mandir}/man1/wodim.*
190 %{_mandir}/man1/readom.*
192 %files -n icedax
193 %defattr(-,root,root)
194 %doc doc/icedax COPYING
195 %{_bindir}/icedax
196 %ghost %{_bindir}/cdda2wav
197 %{_bindir}/cdda2ogg
198 %{_mandir}/man1/icedax.*
199 %{_mandir}/man1/cdda2ogg.*
200 %{_mandir}/man1/list_audio_tracks.*
202 %files -n genisoimage
203 %defattr(-,root,root)
204 %doc doc/genisoimage COPYING
205 %{_bindir}/genisoimage
206 %ghost %{_bindir}/mkisofs
207 %ghost %{_bindir}/mkhybrid
208 %{_bindir}/isodebug
209 %{_bindir}/isodump
210 %{_bindir}/isoinfo
211 %{_bindir}/isovfy
212 %{_bindir}/pitchplay
213 %{_bindir}/readmult
214 %{_mandir}/man5/genisoimagerc.*
215 %{_mandir}/man1/genisoimage.*
216 %{_mandir}/man1/isodebug.*
217 %{_mandir}/man1/isodump.*
218 %{_mandir}/man1/isoinfo.*
219 %{_mandir}/man1/isovfy.*
220 %{_mandir}/man1/pitchplay.*
221 %{_mandir}/man1/readmult.*
223 %files -n dirsplit
224 %defattr(-,root,root)
225 %{_bindir}/dirsplit
226 %{_mandir}/man1/dirsplit.*
228 %changelog
229 * Fri Jul 10 2009 Adam Jackson <ajax@redhat.com> 1.1.9-7
230 - Move dirsplit to a subpackage to isolate the perl dependency.
232 * Tue Jun 15 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-6
233 - rename functions as they conflict with glibc
234 - Don't push cdda2mp3 because we don't have any mp3 coder
235 Resolves: #505918
237 * Tue Jun 02 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-5
238 - Added Requires vorbis-tools in icedax (rhbz #503699)
240 * Wed Feb 25 2009 Peter Jones <pjones@redhat.com> - 1.1.9-4
241 - Add support for EFI boot images.
243 * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
244 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
246 * Thu Feb 12 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-2
247 - Use -fno-strict-aliasing to prevent strict_aliasing warnings/errors
249 * Mon Oct 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.9-1
250 - Bump to version 1.1.9
252 * Tue May 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.8-1
253 - Version 1.1.8 - old patches included
254 - added bzip2-devel to build requirements
255 - fixed #171510 - preserve directory permissions
257 * Wed Feb 27 2008 Harald Hoyer <harald@redhat.com> 1.1.6-11
258 - refined -Werror patch
260 * Mon Feb 25 2008 Harald Hoyer <harald@redhat.com> 1.1.6-10
261 - patched to compile with -Werror (rhbz#429385)
263 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-9
264 - fixed loop on error message for old dev syntax (rhbz#429386)
266 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-8
267 - added file-devel to build requirements
269 * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.6-7
270 - Autorebuild for GCC 4.3
272 * Tue Sep 25 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-6
273 - fixed readcd man page symlink
275 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-5
276 - fixed rhbz#255001 - icedax --devices segfaults
277 - fixed rhbz#249357 - Typo in wodim output
279 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
280 - play stupid tricks, to let alternatives make the links and
281 rpm not removing them afterwards
282 - removed bogus warning for "." and ".."
284 * Thu Sep 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-3
285 - fixed rhbz#248262
286 - switched to alternatives
288 * Fri Aug 17 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-2
289 - changed license to GPLv2
291 * Wed Jun 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-1
292 - version 1.1.6
293 - added readcd symlink
295 * Mon Apr 23 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-4
296 - bump obsoletes/provides
298 * Tue Feb 27 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-3
299 - applied specfile changes as in bug #224365
301 * Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-1
302 - version 1.1.2