1 Summary: A collection of CD
/DVD utilities
6 Group: Applications
/System
7 URL: http
://cdrkit.org
/
8 Source: http
://debburn.alioth.debian.org
/cdrkit
-%{version}.tar.gz
10 Patch1: genisoimage
-dlength.patch
11 Patch2: icedax
-segfault.patch
12 Patch3: wodim
-prtypo.patch
13 Patch4: cdrkit
-1.1.6-oldsyn.patch
14 Patch5: cdrkit
-1.1.6-werror.patch
16 BuildRequires
: cmake libcap
-devel zlib
-devel perl file
-devel
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
21 cdrkit is a collection of CD
/DVD utilities.
24 Summary: A
command line CD
/DVD recording program
25 Group: Applications
/Archiving
26 Obsoletes
: dvdrecord
<= 0:0.1.5
27 Provides: dvdrecord
= 0:0.1.5.1
28 Obsoletes
: cdrecord
< 9:2.01-12
29 Provides: cdrecord
= 9:2.01-12
30 Requires(preun
): %{_sbindir}/alternatives chkconfig coreutils
31 Requires(post
): %{_sbindir}/alternatives chkconfig coreutils
34 Wodim is an application
for creating audio and data CDs. Wodim
35 works with many different brands of CD recorders
, fully supports
36 multi
-sessions and provides human
-readable error messages.
38 %package -n genisoimage
39 Summary: Creates an image of an ISO9660 filesystem
40 Group: Applications
/System
41 Obsoletes
: mkisofs
< 9:2.01-12
42 Provides: mkisofs
= 9:2.01-12
43 Requires: perl
>= 4:5.8.1
44 Requires(preun
): %{_sbindir}/alternatives chkconfig coreutils
45 Requires(post
): %{_sbindir}/alternatives chkconfig coreutils
47 %description -n genisoimage
48 The genisoimage program is used as a pre
-mastering program
; i.e.
, it
49 generates the ISO9660 filesystem. Genisoimage takes a snapshot of
50 a given directory tree and generates a binary image of the tree
51 which will correspond to an ISO9660 filesystem when written to
52 a block device. Genisoimage is used
for writing CD
-ROMs
, and includes
53 support
for creating bootable El Torito CD
-ROMs.
55 Install the genisoimage package
if you need a program
for writing
59 Group: Applications
/Multimedia
60 Summary: A utility
for sampling
/copying .wav files from digital audio CDs
61 Obsoletes
: cdda2wav
< 9:2.01-12
62 Provides: cdda2wav
= 9:2.01-12
63 Requires(preun
): %{_sbindir}/alternatives chkconfig coreutils
64 Requires(post
): %{_sbindir}/alternatives chkconfig coreutils
66 %description -n icedax
67 Icedax is a sampling utility
for CD
-ROM drives that are capable of
68 providing a CD's audio data
in digital form to your host. Audio data
69 read from the CD can be saved as .wav or .sun format sound files.
70 Recording formats include stereo
/mono
, 8/12/16 bits and different
71 rates. Icedax can also be used as a CD player.
75 %patch1 -p1
-b .dlength
77 %patch3 -p1
-b .prtypo
78 %patch4 -p1
-b .oldsyn
79 %patch5 -p1
-b .werror
80 find .
-type f
-print0 | xargs
-0 perl
-pi
-e 's
#/usr/local/bin/perl#/usr/bin/perl#g'
81 find doc
-type f
-print0 | xargs
-0 chmod a
-x
87 export CFLAGS
="$RPM_OPT_FLAGS
-Wall
-Werror
-Wno
-unused
-function -Wno
-unused
-variable"
88 export CXXFLAGS
="$CFLAGS"
89 export FFLAGS
="$CFLAGS"
91 -DCMAKE_INSTALL_PREFIX
:PATH
=%{_prefix} \
92 -DBUILD_SHARED_LIBS
:BOOL
=ON
93 make VERBOSE
=1 %{?_smp_mflags}
96 rm -rf $RPM_BUILD_ROOT
98 make install DESTDIR
=$RPM_BUILD_ROOT
99 perl
-pi
-e 's
#^require v5.8.1;##g' $RPM_BUILD_ROOT%{_bindir}/dirsplit
100 ln
-s genisoimage $RPM_BUILD_ROOT
%{_bindir}/mkisofs
101 ln
-s genisoimage $RPM_BUILD_ROOT
%{_bindir}/mkhybrid
102 ln
-s icedax $RPM_BUILD_ROOT
%{_bindir}/cdda2wav
103 ln
-s wodim $RPM_BUILD_ROOT
%{_bindir}/cdrecord
104 ln
-s wodim $RPM_BUILD_ROOT
%{_bindir}/dvdrecord
107 rm -rf $RPM_BUILD_ROOT
110 link
=`readlink
%{_bindir}/cdrecord`
111 if [ "$link"
== "
%{_bindir}/wodim"
]; then
112 rm -f
%{_bindir}/cdrecord
114 link
=`readlink
%{_bindir}/dvdrecord`
115 if [ "$link"
== "wodim"
]; then
116 rm -f
%{_bindir}/dvdrecord
119 %{_sbindir}/alternatives --install %{_bindir}/cdrecord cdrecord \
120 %{_bindir}/wodim
50 \
121 --slave
%{_mandir}/man1
/cdrecord
.1.gz cdrecord
-cdrecordman \
122 %{_mandir}/man1
/wodim
.1.gz \
123 --slave
%{_bindir}/dvdrecord cdrecord-dvdrecord %{_bindir}/wodim \
124 --slave
%{_mandir}/man1
/dvdrecord
.1.gz cdrecord
-dvdrecordman \
125 %{_mandir}/man1
/wodim
.1.gz \
126 --slave
%{_bindir}/readcd cdrecord-readcd %{_bindir}/readom \
127 --slave
%{_mandir}/man1
/readcd
.1.gz cdrecord
-readcdman \
128 %{_mandir}/man1
/readom
.1.gz
132 %{_sbindir}/alternatives --remove cdrecord %{_bindir}/wodim
136 link
=`readlink
%{_bindir}/mkisofs`
137 if [ "$link"
== "genisoimage"
]; then
138 rm -f
%{_bindir}/mkisofs
141 %{_sbindir}/alternatives --install %{_bindir}/mkisofs mkisofs \
142 %{_bindir}/genisoimage
50 \
143 --slave
%{_mandir}/man1
/mkisofs
.1.gz mkisofs
-mkisofsman \
144 %{_mandir}/man1
/genisoimage
.1.gz \
145 --slave
%{_bindir}/mkhybrid mkisofs-mkhybrid %{_bindir}/genisoimage
147 %preun -n genisoimage
149 %{_sbindir}/alternatives --remove mkisofs %{_bindir}/genisoimage
153 link
=`readlink
%{_bindir}/cdda2wav`
154 if [ "$link"
== "icedax"
]; then
155 rm -f
%{_bindir}/cdda2wav
157 %{_sbindir}/alternatives --install %{_bindir}/cdda2wav cdda2wav \
158 %{_bindir}/icedax
50 \
159 --slave
%{_mandir}/man1
/cdda2wav
.1.gz cdda2wav
-cdda2wavman \
160 %{_mandir}/man1
/icedax
.1.gz
164 %{_sbindir}/alternatives --remove cdda2wav %{_bindir}/icedax
168 %defattr(-,root
,root
)
169 %doc Changelog COPYING FAQ FORK START
170 %doc doc
/READMEs doc
/wodim
173 %ghost %{_bindir}/cdrecord
174 %ghost %{_bindir}/dvdrecord
177 %{_mandir}/man1
/devdump.
*
178 %{_mandir}/man1
/wodim.
*
179 %{_mandir}/man1
/readom.
*
182 %defattr(-,root
,root
)
183 %doc doc
/icedax COPYING
185 %ghost %{_bindir}/cdda2wav
188 %{_mandir}/man1
/icedax.
*
189 %{_mandir}/man1
/cdda2ogg.
*
190 %{_mandir}/man1
/list_audio_tracks.
*
192 %files -n genisoimage
193 %defattr(-,root
,root
)
194 %doc doc
/genisoimage COPYING
195 %{_bindir}/genisoimage
196 %ghost %{_bindir}/mkisofs
197 %ghost %{_bindir}/mkhybrid
205 %{_mandir}/man5
/genisoimagerc.
*
206 %{_mandir}/man1
/genisoimage.
*
207 %{_mandir}/man1
/isodebug.
*
208 %{_mandir}/man1
/isodump.
*
209 %{_mandir}/man1
/isoinfo.
*
210 %{_mandir}/man1
/isovfy.
*
211 %{_mandir}/man1
/dirsplit.
*
212 %{_mandir}/man1
/pitchplay.
*
213 %{_mandir}/man1
/readmult.
*
216 * Wed Feb
27 2008 Harald Hoyer
<harald@redhat.com
> 1.1.6-11
217 - refined
-Werror patch
219 * Mon Feb
25 2008 Harald Hoyer
<harald@redhat.com
> 1.1.6-10
220 - patched to compile with
-Werror
(rhbz
#429385)
222 * Thu Feb
21 2008 Harald Hoyer
<harald@redhat.com
> 1.1.6-9
223 - fixed loop on error message
for old dev syntax
(rhbz
#429386)
225 * Thu Feb
21 2008 Harald Hoyer
<harald@redhat.com
> 1.1.6-8
226 - added file
-devel to build requirements
228 * Mon Feb
18 2008 Fedora
Release Engineering
<rel
-eng@fedoraproject.org
> - 1.1.6-7
229 - Autorebuild
for GCC
4.3
231 * Tue Sep
25 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.6-6
232 - fixed readcd man page symlink
234 * Fri Sep
21 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.6-5
235 - fixed rhbz
#255001 - icedax --devices segfaults
236 - fixed rhbz
#249357 - Typo in wodim output
238 * Fri Sep
21 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.6-4
239 - play stupid tricks
, to
let alternatives
make the links and
240 rpm not removing them afterwards
241 - removed bogus warning
for "." and ".."
243 * Thu Sep
20 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.6-3
245 - switched to alternatives
247 * Fri Aug
17 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.6-2
248 - changed license to GPLv2
250 * Wed Jun
20 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.6-1
252 - added readcd symlink
254 * Mon Apr
23 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.2-4
255 - bump obsoletes
/provides
257 * Tue Feb
27 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.2-3
258 - applied specfile changes as
in bug
#224365
260 * Wed Jan
24 2007 Harald Hoyer
<harald@redhat.com
> - 1.1.2-1