r628: Fix a bug when paste_silence didn't return proper editlist
[cinelerra_cv/mob.git] / libsndfile / libsndfile.spec
blob8fa32ae733c9cb353c53c8d3f029ca5128c8038a
2 %define name libsndfile
3 %define version 1.0.5
4 %define release 1
5 %define prefix /usr
7 Summary: A library to handle various audio file formats.
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 Prefix: %{prefix}
12 Copyright: LGPL
13 Group: Libraries/Sound
14 Source: http://www.zip.com.au/~erikd/libsndfile/libsndfile-%{version}.tar.gz
15 URL: http://www.zip.com.au/~erikd/libsndfile/
16 BuildRoot: /var/tmp/%{name}-%{version}
18 %description
19 libsndfile is a C library for reading and writing sound files such as
20 AIFF, AU and WAV files through one standard interface. It can currently
21 read/write 8, 16, 24 and 32-bit PCM files as well as 32-bit floating
22 point WAV files and a number of compressed formats.
24 %package devel
25 Summary: Libraries, includes, etc to develop libsndfile applications
26 Group: Libraries
28 %description devel
29 Libraries, include files, etc you can use to develop libsndfile applications.
31 %prep
32 %setup
34 %build
35 ./configure --prefix=%{prefix}
36 make
38 %install
39 if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
40 mkdir -p $RPM_BUILD_ROOT
41 make prefix=$RPM_BUILD_ROOT%{prefix} install
43 %clean
44 if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
46 %files
47 %defattr(-,root,root)
48 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO doc
49 %prefix/lib/libsndfile.so.*
51 %files devel
52 %defattr(-,root,root)
53 %{prefix}/lib/libsndfile.a
54 %{prefix}/lib/libsndfile.la
55 %{prefix}/lib/libsndfile.so
56 %{prefix}/include/sndfile.h
57 %{prefix}/lib/pkgconfig/sndfile.pc
59 %changelog
60 * Thu Jul 6 2000 Josh Green <jgreen@users.sourceforge.net>
61 - Created libsndfile.spec.in
62 * Mon Oct 21 2002 Erik de Castro Lopo <erikd@zip.com.au>
63 - Force installation of sndfile.pc file.