2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
11 ifneq ($(ARCH
),powerpc
)
12 CFLAGS
=-ffast-math
-O3
-mmmx
-march
=pentium4
-msse
-msse2
-minline-all-stringops
-fprefetch-loop-arrays
-funroll-loops
13 # CFLAGS=-ffast-math -g -mmmx -march=pentium-mmx
14 CXXFLAGS
=$(CFLAGS
) -fno-check-new
15 CONFFLAGS
+=--enable-mmx
--enable-x86
--without-pic
18 ifneq (, $(findstring smp2
,$(DEB_BUILD_OPTIONS
)))
22 config.status
: configure
24 @if
[ -z
"$(CFLAGS)" ] ; then CFLAGS
="$(CFLAGS)" ; fi
;
25 @if
[ -z
"$(CXXFLAGS)" ] ; then CXXFLAGS
="$(CXXFLAGS)" ; fi
;
26 CFLAGS
="$(CFLAGS)" CXXFLAGS
="$(CXXFLAGS)" \
27 .
/configure
--prefix=/usr
$(CONFFLAGS
)
30 build-stamp
: config.status
33 docbook-to-man debian
/cinelerra.sgml
> debian
/cinelerra
.1
34 docbook-to-man debian
/mplexhi.sgml
> debian
/mplexhi
.1
35 docbook-to-man debian
/mplexlo.sgml
> debian
/mplexlo
.1
42 -rm -f debian
/cinelerra
.1
43 -rm -f debian
/mplexhi
.1
44 -rm -f debian
/mplexlo
.1
47 binary-indep
: checkroot build-stamp
48 binary-arch
: checkroot build-stamp
49 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tmp
50 chmod
-x debian
/tmp
/usr
/lib
/cinelerra
/*
51 chmod
+x debian
/tmp
/usr
/lib
/cinelerra
/fonts
52 chmod
-x debian
/tmp
/usr
/lib
/cinelerra
/fonts
/*
53 dh_install
--sourcedir
=debian
/tmp
--autodest
55 dh_installchangelogs
-a
61 # Since Cinelerra is far from stable, I prefer leaving the debug info
63 strip -x
-s
-R .comment
-R .note debian
/cinelerra
/usr
/lib
/cinelerra
/*.so
65 # AFAIK bootstraping should be gone now -- minmax
67 # Rename defaulttheme to blondtheme
68 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/blondtheme.so plugins/defaulttheme/data/*.png
70 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/bluedottheme.so plugins/bluedottheme/data/*.png
71 # guicast/bootstrap debian/cinelerra/usr/bin/cinelerra cinelerra/data/mode_*.png
72 # not present anymore?
73 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/microtheme.so plugins/microtheme/data/*.png
82 binary
: binary-indep binary-arch