r793: Small API addon, so plugins can 'see' camera and projector automation
[cinelerra_cv/mob.git] / debian / rules
blob4eebba67efe9fd9e94481dee8466c74e7128a544
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 package=hvirtual
6 export DH_COMPAT=4
8 CONFFLAGS=
9 ARCH=$(DEB_HOST_ARCH)
11 ifneq ($(ARCH),powerpc)
12 CFLAGS=-ffast-math -O3 -mmmx -march=pentium4 -msse -msse2 -minline-all-stringops -fprefetch-loop-arrays -funroll-loops
13 # CFLAGS=-ffast-math -g -mmmx -march=pentium-mmx
14 CXXFLAGS=$(CFLAGS) -fno-check-new
15 CONFFLAGS+=--enable-mmx --enable-x86 --without-pic
16 endif
18 ifneq (, $(findstring smp2,$(DEB_BUILD_OPTIONS)))
19 MAKEFLAGS=-j2
20 endif
22 config.status: configure
23 $(checkdir)
24 @if [ -z "$(CFLAGS)" ] ; then CFLAGS="$(CFLAGS)" ; fi ;
25 @if [ -z "$(CXXFLAGS)" ] ; then CXXFLAGS="$(CXXFLAGS)" ; fi ;
26 CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" \
27 ./configure --prefix=/usr $(CONFFLAGS)
29 build: build-stamp
30 build-stamp: config.status
31 $(checkdir)
32 $(MAKE) $(MAKEFLAGS)
33 docbook-to-man debian/cinelerra.sgml > debian/cinelerra.1
34 docbook-to-man debian/mplexhi.sgml > debian/mplexhi.1
35 docbook-to-man debian/mplexlo.sgml > debian/mplexlo.1
36 touch build-stamp
38 clean:
39 $(checkdir)
40 -$(MAKE) -i distclean
41 dh_clean -a
42 -rm -f debian/cinelerra.1
43 -rm -f debian/mplexhi.1
44 -rm -f debian/mplexlo.1
45 -rm -f build-stamp
47 binary-indep: checkroot build-stamp
48 binary-arch: checkroot build-stamp
49 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
50 chmod -x debian/tmp/usr/lib/cinelerra/*
51 chmod +x debian/tmp/usr/lib/cinelerra/fonts
52 chmod -x debian/tmp/usr/lib/cinelerra/fonts/*
53 dh_install --sourcedir=debian/tmp --autodest
54 dh_installdocs -XCVS
55 dh_installchangelogs -a
56 dh_installman
57 dh_installmenu
59 dh_fixperms -a
60 dh_compress -a
61 # Since Cinelerra is far from stable, I prefer leaving the debug info
62 dh_strip -a
63 strip -x -s -R .comment -R .note debian/cinelerra/usr/lib/cinelerra/*.so
65 # AFAIK bootstraping should be gone now -- minmax
67 # Rename defaulttheme to blondtheme
68 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/blondtheme.so plugins/defaulttheme/data/*.png
69 # Add bluedottheme
70 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/bluedottheme.so plugins/bluedottheme/data/*.png
71 # guicast/bootstrap debian/cinelerra/usr/bin/cinelerra cinelerra/data/mode_*.png
72 # not present anymore?
73 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/microtheme.so plugins/microtheme/data/*.png
75 dh_makeshlibs -V -a
76 dh_shlibdeps -a
78 dh_gencontrol
79 dh_builddeb
82 binary: binary-indep binary-arch
84 checkroot:
85 dh_testroot