2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
8 CFLAGS
=-ffast-math
-O3
-mmmx
-g
9 CXXFLAGS
=$(CFLAGS
) -fno-check-new
12 ifneq (, $(findstring smp2
,$(DEB_BUILD_OPTIONS
)))
16 config.status
: configure
18 CFLAGS
="$(CFLAGS)" CXXFLAGS
="$(CXXFLAGS)" \
19 # ./configure --prefix=/usr --enable-x86 --without-pic
20 .
/configure
--prefix=/usr
--enable-mmx
--enable-x86
--without-pic
23 build-stamp
: config.status
26 docbook-to-man debian
/cinelerra.sgml
> debian
/cinelerra
.1
27 docbook-to-man debian
/mplexhi.sgml
> debian
/mplexhi
.1
28 docbook-to-man debian
/mplexlo.sgml
> debian
/mplexlo
.1
33 -[ -r Makefile
] && $(MAKE
) -i
distclean
35 -rm -f debian
/cinelerra
.1
36 -rm -f debian
/mplexhi
.1
37 -rm -f debian
/mplexlo
.1
40 binary-indep
: checkroot build-stamp
41 binary-arch
: checkroot build-stamp
42 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tmp
43 chmod
-x debian
/tmp
/usr
/lib
/cinelerra
/*
44 chmod
+x debian
/tmp
/usr
/lib
/cinelerra
/fonts
45 chmod
-x debian
/tmp
/usr
/lib
/cinelerra
/fonts
/*
46 dh_install
--sourcedir
=debian
/tmp
--autodest
48 dh_installchangelogs
-a
53 # Since Cinelerra is far from stable, I prefer leaving the debug info
55 # strip -x -s -R .comment -R .note debian/cinelerra/usr/lib/cinelerra/*.plugin
56 plugins
/bootstrap debian
/cinelerra
/usr
/lib
/cinelerra
/defaulttheme.plugin plugins
/defaulttheme
/data
/*.png
57 plugins
/bootstrap debian
/cinelerra
/usr
/lib
/cinelerra
/microtheme.plugin plugins
/microtheme
/data
/*.png
66 binary
: binary-indep binary-arch