r125: This commit was manufactured by cvs2svn to create tag 'r1_1_7-last'.
[cinelerra_cv/mob.git] / hvirtual / debian / rules
blobfc2a76741a0fdd1253429b815b48b93973515748
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 package=hvirtual
6 export DH_COMPAT=4
8 CFLAGS=-ffast-math -O3 -mmmx -g
9 CXXFLAGS=$(CFLAGS) -fno-check-new
11 MAKEFLAGS=
12 ifneq (, $(findstring smp2,$(DEB_BUILD_OPTIONS)))
13 MAKEFLAGS=-j2
14 endif
16 config.status: configure
17 $(checkdir)
18 CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" \
19 # ./configure --prefix=/usr --enable-x86 --without-pic
20 ./configure --prefix=/usr --enable-mmx --enable-x86 --without-pic
22 build: build-stamp
23 build-stamp: config.status
24 $(checkdir)
25 $(MAKE) $(MAKEFLAGS)
26 docbook-to-man debian/cinelerra.sgml > debian/cinelerra.1
27 docbook-to-man debian/mplexhi.sgml > debian/mplexhi.1
28 docbook-to-man debian/mplexlo.sgml > debian/mplexlo.1
29 touch build-stamp
31 clean:
32 $(checkdir)
33 -[ -r Makefile ] && $(MAKE) -i distclean
34 dh_clean -a
35 -rm -f debian/cinelerra.1
36 -rm -f debian/mplexhi.1
37 -rm -f debian/mplexlo.1
38 -rm -f build-stamp
40 binary-indep: checkroot build-stamp
41 binary-arch: checkroot build-stamp
42 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
43 chmod -x debian/tmp/usr/lib/cinelerra/*
44 chmod +x debian/tmp/usr/lib/cinelerra/fonts
45 chmod -x debian/tmp/usr/lib/cinelerra/fonts/*
46 dh_install --sourcedir=debian/tmp --autodest
47 dh_installdocs -XCVS
48 dh_installchangelogs -a
49 dh_installman
51 dh_fixperms -a
52 dh_compress -a
53 # Since Cinelerra is far from stable, I prefer leaving the debug info
54 # dh_strip -a
55 # strip -x -s -R .comment -R .note debian/cinelerra/usr/lib/cinelerra/*.plugin
56 plugins/bootstrap debian/cinelerra/usr/lib/cinelerra/defaulttheme.plugin plugins/defaulttheme/data/*.png
57 plugins/bootstrap debian/cinelerra/usr/lib/cinelerra/microtheme.plugin plugins/microtheme/data/*.png
59 dh_makeshlibs -V -a
60 dh_shlibdeps -a
62 dh_gencontrol
63 dh_builddeb
66 binary: binary-indep binary-arch
68 checkroot:
69 dh_testroot