2 # -*- mode: makefile; coding: utf-8 -*-
4 # Uncomment this to turn on verbose mode.
9 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
10 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
14 ifneq (,$(findstring debug
,$(DEB_BUILD_OPTIONS
)))
15 CFLAGS
+= -O0
-ggdb
-rdynamic
-MD
-MP
-D DEBUG
-D VALGRIND
16 EXTRA_ARGS
= --with-backtrace
21 ifneq (,$(findstring profiling
,$(DEB_BUILD_OPTIONS
)))
30 CFLAGS
="$(CFLAGS)"; LDFLAGS
="$(LDFLAGS)"; .
/configure
--host
=$(DEB_HOST_GNU_TYPE
) --build
=$(DEB_BUILD_GNU_TYPE
) \
42 rm -f build-stamp
install*-stamp
44 [ ! -f Makefile
] ||
$(MAKE
) distclean
48 install: install-stamp
49 install-stamp
: build-stamp
55 $(MAKE
) DESTDIR
=`pwd`/debian
/tmp
install
59 # Build architecture-independent files here.
60 binary-indep
: build
install
63 # dh_installdocs -i -A README
64 # dh_installchangelogs -i debian/no-upstream-changelog
65 # dh_install -i --sourcedir=debian/tmp
76 # Build architecture-dependent files here.
77 binary-arch
: build
install
80 dh_installchangelogs
-a
-plibcitadel2
82 dh_install
-a
--sourcedir
=debian
/tmp
84 dh_strip
-a
--dbg-package
=libcitadel2-dbg
95 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
97 binary
: binary-indep binary-arch
98 .PHONY
: build
clean binary-indep binary-arch binary
install